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About the User Guide — Defect Manager for Windows

This guide describes how to use Defect Manager for Windows and how the client/server
version of this product can serve your issue reporting, tracking and resolution needs.

The purpose of this guide is to assist you in learning what you can do and how to do it
with Defect Manager for Windows.

Additional information on the purpose of Defect Manager can be found in sections:
What is Defect Manager?, What are the Benefits of Defect Manager?

Other Defect Manager Guides

The User Guide — Defect Manager for Windows has the following companion guides that
provide additional detail on specific topics for Defect Manager:

Getting Started Guide

Installation Guide

User Guide — Defect Manager for Web
User Guide — E-Tech Support Guide
Administration Guide

Programmer APl Guide

Glossary

Purpose of the System

Defect Manager is an interactive software product that allows companies, large and
small, to manage the capture, tracking and resolution of issues and other issues related to
its products, projects, processes or services.

In fact, Defect Manager should be thought of as an “Issue Management System” since
issues and problems with products, projects, processes and services are merely a subset of
issues that may be reported, tracked and managed. Reports of issues can come from
customers as well as your staff and outside contractors. Such reports on issues may
include actual issues, perceived issues, enhancements requests, questions, requests for
action or service.

The purpose of Defect Manager is to provide tools you need to capture, track and resolve
all reported issues while maintaining effective communications with stakeholders on each
issue.
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How the System Works — Using Defect Manager for Windows

Issue-Item Tracking Process

It is important to remember that every company has different goals and objectives as well
as different regulations, policies and procedures that affect how it operates.

There are many ways that you can track issues and issues as well as different
methodologies to accomplish this. In fact, almost everyone that deals with issues and
issues will have their own opinion or an existing business process for how this should be
done.

What most companies lack is an effective tool for tracking and resolving reported issues
and issues -- Defect Manager is designed with the flexibility to meet your company’s
need for better control throughout the complete issue/issue tracking lifecycle.

Although each company is different, your business processes, concepts and terminology
can be accommodated in your use of Defect Manager.

Client Communications Process

As your support staff uses Defect Manager to track and resolve issues, problems and
enhancements, it should not be working in a vacuum. Your clients, the people you serve
and support, can be an integral part of your business process as well.

Defect Manager includes configurable features automatically remind your staff and
communicate with your clients when significant events occur during issue item
processing such as opening an item to begin work or closing an item when the problem is
resolved. This automated as well as user-initiated communication can be facilitated by
Defect Manager to send appropriately formatted emails to clients and other stakeholders
for an issue item.

The Defect Manager E-Tech Support application provides a web-based application to
allow your clients to easily browse your Knowledgebase of prior problems and solutions
as well as interactively submit issues, issues and enhancement requests to you. Your
clients can also use the system to check on the status of the issues they submitted. If the
support team tells a client that they need more information, the client can add the
requested information as a note or file attachment to the issue item in the Defect Manager
Repository.

Defect Manager not only improves the communication and relationships with your
clients, it makes your client your “partner” where his problems are also your problems
and you are solving them together using integrated automation — Defect Manager.
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What are Issue Items?

The term, Issue Item, refers to an object in the repository database that maintains all of
the accumulated information related to an issue or issue that has been reported.

Thus an issue or issue that is submitted to you and entered into the repository, generates
an Issue Item that can be tracked and have all of the related information that describes it
associated in the repository database as a single item — a single object.

The Issue-Item object provides you with the convenience of being able to easily access
any of its descriptive properties and associated collections of notes, documents, pictures,
testing results to efficiently view, update and process the issue item.

As you process an Issue Item, you can add your findings, notes, and updates to its
properties and collections that reflect your contribution to the processing of the issue item
— Hence, the system is tracking your work on the issue item.

When your part of the processing work is done, the Issue-Item can be conveniently
passed as a single object containing all its properties and associated information
collections, including those you just made, to the next work step required to complete its
processing.

Issue Items are the basic objects in the repository that allow you to track and manage
reported issues such as: issues, enhancement requests, suggestions, questions, requests for
action or service, etc. The main window, the Issue Log form, in Defect Manager for
Windows provides you with many ways to query and view issue items, plus it allows you
to select issue items to view or process.

Issue-ltems Properties and Collections

The properties of an issue-item object are of the following types;

= |dentifying property — A field that uniquely identifies an issue item allowing it to be
accessed quickly

= Coded-Value properties — Fields that accept only pre-defined code-values to insure
data consistency and make it easy for a user to select the appropriate value from a
drop-down list of values.

= Timestamp and Schedule properties — Schedule and tracking dates and time values

= Descriptive properties — text information characterizing the problem or groups of
data fields that provide additional description of an issue item

A Collection is a group of files containing information related to an issue-item object
that are registered and linked in the Defect Manager Repository.
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Identifying Properties

Id Number — Whenever you create a new issue item, Defect Manager automatically
assigns it a unique identifier value as the issue-issue Id number. This unique identifier
for an issue item is disclosed to the individual that submitted it. The issue Id number
allows fast and unambiguous query access to each issue/issue item.

Coded-Value Properties

These fields contain pre-defined code values to insure that consistent data is entered and
make it easy for a user to select the appropriate field value from a list of values.

The use of the system is made easier because of the ability for your system administrator
has the ability to add, delete and change most of the sets of code values to make them
familiar and appropriate codes for your organization.

Status — Defect Manager provides three (3) primary-status type values for an issue item
that you control with certain built-in menu-bar operations (shown below) on the -Issue
Window:

1. Open Issue

2. Closed Issue Action—> Close

3. Deferred Issue Action = Defer
The primary-status type values are fixed and built-in. However within each primary-
status value, the status codes you use can be tailored to provide three (3) sets of status-
code values that meet the needs of your organization and your business process.

File = New

The status of an issue is determined by a combination of its primary status and one of its
secondary status values.

The table, shown below, lists the default sets of status-code values for each primary-
status code. These status-code sets can be changed by adding and deleting values, from
within each group, to meet your organization’s needs.

Open lIssue Closed Issue Deferred Issue
New Bug Need System Setup
Verified As Bug Not A Bug Waiting on Client
Fix Made Documentation Error
Fix Verified How To
Fix in Progress Not Reproducible
Packaged Working As Designed
On Hold
Investigating
Client Confirm Fix

Severity — Processing severity for an issue item is defined in terms of code names that
indicate the severity of a issue or importance of an issue. Severity code definitions
consist of a severity name and a numerical severity sort value. The numeric severity sort

WN-8
© Copyright 1999-2006 Defect Manager, Inc. All rights reserved.



pawarsd By .
. . Tiera
Defect Manager 4.5 User Guide — Defect Manager for Windows EsRrymal:

value allows issue items to be sorted in the order of its severity with zero (0) being the
highest severity with the greatest urgency for resolution.

Default severity definitions are shown below which can be customized by the Defect
Manager Administrator program to meet your organizations needs.

Severity Name Severity Sort Value
System Down 0
System Crash 100
Loss of Functionality 200
Minor Issue 300

Note: By leaving gaps in the numerical severity sort values assigned, it is possible at a
later time to create new levels of severity within the existing severity assignments.

Priority — Processing priority for an issue item is defined in terms of code names that
indicate the priority of an issue or importance of an issue. Priority code definitions
consist of a priority name and a numerical priority sort value. The numeric priority sort
value allows issue items to be ranked in the order of its priority with zero (0) being the
highest priority with the greatest urgency for resolution.

Default priority definitions are shown below which can be customized by the Defect
Manager Administrator program to meet your organizations needs.

Priority Name Priority Sort Value

0

100

200

Al W N

300

Note: By leaving gaps in the numerical priority values assigned, it is possible at a later
time to create new levels of priority within the existing priority assignments.

Extensible Coded Value Sets — Defect Manager allows other types of entities to be
named and referenced with code values appropriate to your organization:

= Work Queues — Meaningful names for processing steps in your organization’s
workflow process can be defined where work is held while awaiting attention and
processing. Meaningful names for work queues also assist in routing work to the next
processing step while identifying the nature of the processing at each work step.

= Users — Names of workers and their profiles of permissible operations can be defined.
These user names can be chosen from a list of values for the Assigned To field that
indicates the person responsible for processing an issue item.
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Product Names — Names for the things you support in your organization such as
products, projects, processes or services.

Product Releases — Code names that describe the versions or releases for the things
you support in your organization.

Groups — Names for pairings of one or more Product Names and multiple User
Names that indicate: “the Group of Users that support the Product Name(s) listed”.
Groups provide the means for the system to provide an appropriate list of users for
you to select from when assigning an issue item to an individual.

Components — Meaningful names for component elements that your organization
must support or work with that may be subdivisions of products, platforms or other
entities. The Components property and code values provide an additional level of
granularity and classification for an issue item.

Platform Names — Code values that represent a physical context for an issue. Some
examples of application areas and physical context are:

o0 Software - Computer System Type: Windows, Macintosh, Solaris, Linux
o Hardware = Environment Used: Clean Room; Lab, Office, Warehouse

0 Field Test > Test Group/Situation: Control Group, Placebo Group,
Random Sample

Platform Releases — Code values that represent specific versions of the physical
context. Some examples of application areas and versions of physical contexts are:

o Software = Windows 98, Windows 2000, Windows XP

o Hardware - Clean Room: Standard 1, Standard 2, Standard 3

0 Field Test = Test Group: 2001 Tests, 2002 Tests, 2003 Tests
Products — Groupings for combinations of:

0 Product Names

0 Product Releases

0 Default Assignments

Clients/Users, Locations, and Contacts
Your clients and users can have their location and contact information stored in the
Defect Manager’s Repository database.

Timestamp and Schedule Properties

Entered On -- The date the issue item was entered.
Reported Date — The date the issue was reported
Last Updated -- The last time anyone updated the issue item

Closed On -- The latest date the issue item was resolved and status indicated as
“Closed”.
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e Due On -- The latest date the issue item is expected or to be resolved. The date
represents a planned “on or before” date or it reflects an urgent milestone related to
the issue item and its stakeholders.

Descriptive Properties
Summary — A brief description of the issue or a issue.

Description -- A long description of an issue or issue.
Revision — The revision of the product and release, such as a build number.

Tabs — The bottom half of the Detail Issue Form window has tabs that contain a wealth
of information related to an issue item. The tabs let you selectively view additional
groups of descriptive information as follows:

= General Tab -- This is general information about the issue/issue.

= Resolution Tab -- This tab is used to review the information that is required to
resolve this issue. You specify the resolution when you close the issue item.

= Internal Activity Tab -- These are activities and notes that have been entered by
your technicians that are pertinent to resolving the issue. These notes remain private
and internal to your company. The activity notes that should be accessible by clients
using the E-Tech Support interface, should be placed in the External Activity Tab
(see below).

It is a good practice for your technicians to add notes for all the work that they have
done on a issue item, so that anybody can pick up and continue work on the issue
item, if need be.

For example, if the individual is reassigned to another task, you will not loose the
investigative work that has already been done. You should always document the time
and effort you have spent on resolving your client’s issues.

To add notes to a issue use the Update -> Activity menu item.

= External Activity Tab -- These are activities and notes that have been entered by
your technicians and clients via the web interface. Since your clients can see these
comments, make sure you technicians use appropriate language and suitable remarks.

To add notes to a issue, use the Update > Activity menu item or the updates notes
tool bar button.

If you will not be using the E-Tech Support interface, you can use the
View ->Customize option to hide this tab from view.

= User Defined Tab -- User defined fields allow you to extend Defect Manager to
better suit your organizations needs. You can use up to eight (8) custom fields to
hold data of a specified type that is appropriate for your organization’s issue-
processing needs.
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These fields are defined by using the Defect Manager Administrator tool. You can
also change the label that appears on this tab from within this tool. See the
Administration Guide for more information on defining these fields.

Bookmark Tab — This area is used to view and maintain key words that serve as
bookmarks that allow you and others to quickly locate an issue item or multiple issue
items associated with the same key-word bookmark.

Issue-1tem Collections

Collections are groups of files containing documents, digital pictures, source code, text
files, sets of test result data, etc. that are related to an issue item.

Defect Manager provides the following types of collections:

Attachments — Typically attachments are documents, source code segments, digital
images of photographs or faxes, memory dumps and any other files of information
that are related to an issue item. This information includes information files that
were submitted by the individual reporting the issue as well as those attached by
workers while an issue item was processed.

You can add, remove and view attachments.

Attachments to an issue item are logged immediately -- update is not postponed
until a Save operation. If you realize you have made a mistake when making an
attachment, you can reverse your change.

Notes — Notes can be added to the journals for both Internal and External Activities
to document the progress of work on each issue item.

System Test — Testing Results in multiple files can be included as a group
representing each test done while processing an issue item.

Your System Test department can log system test information related to this issue.
You can even import issue reports from other regression testing tools into this
collection.

Source Files — Your technicians can track multiple source code segments, date
accessed, version of the source code and current status code.

Source file changes made on this tab are logged immediately -- update is not
postponed until a Save operation. If you realize you have made a mistake when
modifying a Source Files collection on an issue item, you can reverse your changes.

When Visual Source Safe is used, Defect Manager allows software program code
modules to be checked in an out during this process and the actions logged in the
Repository.

The Source Files tab is primarily for use by companies involved in tracking
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issues/issues with software products, applications and web-sites; however, it can be
applied to forms of text other than program-source code.

With the exception of the Attachments, Notes and Source Files tabs, all other changes
are temporary until you the use the File=>Save menu item, or press the Save toolbar
button.

When you save an issue item all modifications are logged by the system. You can review
these activities by selecting the Internal Activity and External Activity tabs.

Repository and Activity Log
The Defect Manager Repository is the central database for the Defect Manager system.

It organizes all of the issue items and related information needed enter, track and resolve
issues/issues.

Both versions of Defect Manager, the “ ... for Windows” and “... for Web”, utilize this
database and provide their users with access.

A key part of this repository database is the Activity Log that stores a record of all
activities that are done to issue items while using Defect Manager.

Knowledgebase

The Knowledgebase is a separate database that is available as WEB pages over the
Internet/Extranet network by using the E-Tech Support system. Only selected issue
items that you decide to publish to this Web-database are available for viewing by
issue/issue stakeholders and clients authorized to use the E-Tech Support system.

Likewise, Internal Actions, Notes, Source Code, and Test Results are not included when
an issue item is published, but the External Actions and Notes are included along with
other properties

Workflow and Work Queues

What is Workflow?

Workflow is a method for processing issue items that typically require multiple work
steps to complete its processing and it may also involve several different groups and
individuals.

Defect Manager is designed to use Workflow because the processing of reported issues
and issues is typically done in multiple work steps that often involve different groups and
individuals. Each work step, or stage of work, will have a specific group or individual
that is trained and possesses the skills to do the work required at this point in the
processing of an issue item.

Workflow is a useful technique for both large and small organizations. Workflow can be
applied to small organizations that may be a “One-Man-Band” who has many things
going on and interruptions. Defect Manager workflow can help him organize and track
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the pending, in-process and resolved issues he must contend with on a daily basis to
insure the important work and tasks do not get lost in the “cracks”.

The large organization may need and use many specialists that must co-operate during
the life-cycle a reported issue. Workflow provides an effective way to “flow” the work
between many cooperating individuals and organizations while tracking and helping to
prevent any of the related issue item information from becoming lost.

What is a Work Queue?

As work flows between work steps and different workers, it is rarely a smoothly running
assembly line where each of the work steps are synchronized by a common “conveyer
belt” as you might imagine as running in an ideal factory.

As | am sure you are aware, processing issues and issues is normally done by
independent groups and individuals — This typically requires that the workflow be
asynchronous because these workers are not immediately available when work arrives.

Work Queues are an effective way to allow an issue item to flow to the next work step
and be held until an appropriate worker is able to process it. Work queues should have
meaningful names to make it easy to route each issue item to the next work step.

Specific groups or individuals obtain issue items to process from a named work queue.
After completing the appropriate processing at a work queue, the issue item is then
placed in the work queue for the next step in the process. Such workflow processing
continues until the final work step is completed and the issue item is deferred or closed.

The names assigned to work queues should be meaningful terms within your business
process. Work-queue names should reflect either the type of work performed in the work
step or the group or individual that obtains work from the work queue.

It is recommended that the names be descriptive generically, rather than using the names
of individuals who may be re-assigned. For example, use a generic description such as
“QA Tester” rather than “Bill”.

Issue Processing Steps

Issues and issues are typically reported by: your customers, the system test or QA teams,
technical support teams, help desk, sales support teams, documentation teams,
management, and system integrators. Regardless of whom the issue is reported by, it is
important that you log each and every issue. To properly address and resolve the issue it
IS important that:

e A priority level is set for the reported issue based on its severity. The most
important issues should get resolved first.

e Your staff works on the issues in priority sequence.

e All effort spent on each issue is logged. This will give you the ability to re-assign
the issue to another technician without losing the investigative work previously
performed.
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e Bookmarks are associated with this issue, so others can easily find all the relevant
information related to this type of issue. This helps you to start building a
coherent knowledgebase.

Once a issue is reported, the issue should be put into a verification queue, so that
someone can verify if this is a issue, or not. The following sections characterize the
basic process from a software issue and issue processing point of view. Other
applications for Defect Manager will have similar considerations in their respective
contexts and environments.

Issue Verification

System Test or Technical Support usually review reported issues and verify if they are in
fact a issue. If is not a issue, the client must be notified that it is not a issue and why. If it
is a issue, it must be passed to appropriate group (usually development or support) to be
fixed.

Issue Correction

Based on the type of issue, there could be any number of skilled individuals that can
correct the issue. You want to make sure that these individuals have a list of all the issues
that they are expected to fix, an associated priority in which they should be worked on,
and a scheduled date that they need to have the fix completed by. These individuals are
typically software developers, documentation writers, graphic artists and release
management engineers, etc.

As they work on the issues that are assigned to them they should keep notes on
everything they have done to progress on the issue. After they have fixed the issue they
need to pass it on to the group that will verify that the issue is corrected. These fixes
should also be checked into the source code control system.

Issue Correction Verification

After the fix is made it needs to be passed to the group that will verify that it has truly
been corrected. Usually, the System Test group does this work.

Issue Delivery

Usually, management (based on the client need or marketing need) determines when the
issue corrections (fixes) needs to be completed and when it should be targeted for
delivery.

Fixes are scheduled as a hot fix/patch into the production product, distributed as problem
notices with documentation of fixes or workarounds, or they are targeted for a particular
release in the future. The nature of fixes and how they are deployed depends on your
type of business and products that are being supported.
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The fix is deployed and delivered to the client along with a notice that the issue/issue has
been resolved. The issue is closed. A final resolution is recorded. The failing component

area is recorded.
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Example of Workflow with Work Queues for each Work Step.

The following is a general example of workflow processing. The processing of reported
issues could follow this workflow for our example company as shown in the figure
below.

ooo
ooo

Communications

Workstation

Internet / Extranet
Wide Area
Network

Issue Receiving

Y

Defect Manager

Defect Manager
for Windows

for Web

E-Tech Support

v

y

‘

Verification &
Routing
Work Queue

v

Defect Correction
Work Queue A
(Development)

v

A

Defect Correction
Work Queue B
(Maintenance)

v

Defect Correction
Work Queue C
(Database)

Y

Rework

Y

Correction
Verification
Work Queue

Y

Finalization
Work Queue

Close
Issue Item
Re-Open
Issue Item

Notify
Issue ltem
Stakeholders

Figure: A Sample Workflow Sequence

WN-17

© Copyright 1999-2006 Defect Manager, Inc. All rights reserved.



Fﬂ"_"',irf\

. . Tiera
Defect Manager 4.5 User Guide — Defect Manager for Windows EERTTRATS

The following outline describes the example workflow process shown in the above
figure. This example begins with a report of a issue over the phone or via the internet
which initiates the following action and subsequent work steps:

= |nitial Actions:

1. Receive the issue report and enter it into Defect Manager storing it in the
Repository.

2. The new issue item is placed in the work queue named: Verification & Routing.

3. Optionally, the issue item may also be assigned to a specific individual that is
responsible for processing this issue.

= Subsequent Work Steps:

1. An assigned worker for the work queue accesses the highest priority issue item
from the work queue named: Verification & Routing.

Work-Step Actions: Review the issue item properties and collections for
completeness and accuracy. Determine the Next work queue that should process
the issue item and if a specific user should be Assigned To work on it at the next
work step.

If the issue item is incomplete, defer the item while taking action to obtain the
missing elements needed — once obtained, re-activate the issue item and continue.

Post-Process Actions: Send the issue item to the next appropriate work step for
processing by individual(s) with appropriate skills and training by placing the
issue item into the proper work queue (e.g., “Issue Corrections”). Likewise, if a
specific individual should process it, assign the individual’s name in the Assign
To field for this issue item.

2. Assigned worker accesses the highest priority issue item from the work queue
named: Issue Corrections. ( Note: The issue item fetched next may or may not
be the one shown in step one above, since a higher-priority issue item may take
precedence)

Work-Step Actions: Review the issue item properties and collections to
understand the nature of the issue or issue. Research and, attempt to, resolve the
issue or issue. Log all actions taken, attach information and materials gathered
that should be retained and update the status of the issue item as appropriate.

Post-Process Actions: Send the issue item to the appropriate next work step for
processing:
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= |If the issue item needs additional processing by other groups/specialists,
assign the work to those individuals by placing this issue item in the
appropriate work queue

= |f this work-step processing is completed, then place this issue item in the next
appropriate work queue: Correction Verification

3. An assigned worker accesses the highest priority issue item from the appropriate
one of the three work queues named: Correction Verification.

The workflow diagram, shown above, shows three different queues that are use to
hold and provide issue items to workers with different specialties in issue
corrections. One or more workers know which work queues they are assigned to
use.

The Assign To field can further route the issue to a specific worker because
he/she is responsible for the issue item or because he/she is best able to process it
at this time.

Work-Step Actions: Review the issue item properties and collections to insure
that the issue item is completed properly with all of its accumulated information
accurately logged. Verify that the correction is indeed valid and complete.

Note: In the case of a software bug and bug-fix correction, this work queue might
be called “System Test”, QA-Quality Assurance, etc. This group must plan and
test the correction to insure that it is valid, complete and can be deployed with the
planned release. In addition, work-around suggestions and solutions may be
identified to provide immediate relief from the issue until the next release can be
obtained and installed.

Post-Process Actions: Send the issue item to the appropriate work step for

processing:

= |f this issue item does not meet the quality standards required by your
business process, update its status and route it to the appropriate work queue
for re-work.
The workflow diagram, shown above, indicates that the company’s policy is
to send re-work to the Verification & Routing work queue (shown with
connector marked RW) so the individual working this queue will be able to
verify that the issue does need re-work and assign it to an appropriate worker
to correct the problem.

= |f this issue item meets the quality standards required by your business
process, place it in the work queue named: Finalization.

4. Assigned worker accesses the highest priority issue item from the work queue
named: Finalization.

Work-Step Actions: Send appropriate follow-up responses to all issue-item
stakeholders. These responses would advise of the disposition of the reported
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issue or issue, plans for deployment a solution and any work-around suggestions
or solutions that could provide immediate relief.

Review the issue item to determine if it should be published to the
Knowledgebase to allow staff and customers to find previously resolved issues
and issues along with the solution.

Update the issue item information required to track the finalization actions
performed in this work step.

Post-Process Actions:

= |f this issue item does not meet the quality standards required by your
business process, update its status and route it to the appropriate work queue
for re-work.

= |f this issue item meets the quality standards required by your business
process, update it as “closed” which removes it from workflow.

This simple workflow example has been kept very simple and generic to illustrate the
concepts of workflow processes and issue-tracking lifecycle built around work queues.

We designed this example to show how you can combine quality control and issue
processing steps that are done by different individuals and to:

= |llustrate how independent steps and workers can collaborate effectively

= Emphasize that by injecting quality control work steps at the beginning and end of a
process that is done by multiple independent workers provides checks and balances
to insure that work is ready for processing before it is assigned; Likewise, it insures
that the processed work is correct before telling your customers and stakeholders
that you have resolved the problem.

= Demonstrate that work can flow asynchronously and be accessed in priority order as
it is delivered to workers at their desktop computers.

The administrator for your installation of Defect Manager will need to define and name
the work queues that best suit your organization’s needs for processing your reported
issues and issues (see the Administration Guide).
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Basic System Operations

This section covers the basic operations needed to routinely add and process issues and
issues while using Defect Manager for Windows.

A separate section, Advanced System Operations, describes the more specialized
operations.

Logging On To Defect Manager for Windows

You begin by logging onto the system allowing it to recognize you as a pre-defined user
and the permissions you are authorized to use. The logon window below will be
displayed.

x

Izer Mame:

Password: I “““““

Mate: zer Mame and Pazsword are caze sensitive.

¥ Femember User Mame and Password for nest time

Lagan I Cancel |

Figure: Defect Manhager [L,og Onh Form

Staff users have issues/issues assigned to them and perform work on it as a part of the
process to resolve a problem or address an issue. Staff-users can be people who: answer
support calls, do development, manage projects, test systems, document systems, produce
graphics, manage product configurations, etc. — Anyone who is a part of your
organization’s issue/issue resolution business process.

Users are defined by the administrator(s) of the system who configure each user with
suitable permissions and parameters.

If you are an administrator, you will also want to read the section: Configuring Usersin
the Administration Guide to see how to add new users to the system.

If you do not know your password, contact your administrator, and they can provide you
with your User Name and Password to log onto Defect Manager.

Once you are logged on to the system you can use the Defect Manager Log display grid
to select, then view or process reported issues and issues.
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Issue Log Window — Main Window

The main window of Defect Manager displays a log of issue items for you to select and
view as shown in the figure below

Menu Bar
Standard Tool

Bar
Project Tool Bar

Reported By Tool
Bar

Issue Log Display
Grid

Status Line

T

% Defect Manager Log [M=[x|
TFle Fiter Reports Stafistics Configuration View Help

L 208/ B| 5] BlEE| BE| A D L@ 0 5 sl

| [Help Deskc | [Retease 3.0 | [anUsers ] [anTypes x| [arstatuses -

v [intemal | [arLocations | [ Types | [anStatuses ~|

1d [ Type [ yProduct [ yRelease [ Revision [ ysummary [ yCompanent

£ Defect Help Desk Release 3.0 My server is crashing after Hardware

#® 1 Defect Help Desk Release 3.0 System FCO02 is returning Hard:

k) i ;
@y\ Admin logged on at 01,02,2006 - 19:37:54  [Fiter By: Help Desk, Release 3.0, All Users, All Types, Al Statuses [2]

Figure: Defect Mahager for Windows — Main Window -Jssue-[,08

Display

In addition to the Menu Bar and the Toolbar operations, you can also use the Right-
Mouse Button pop-up menu to evoke operations on the item under the cursor. This is
only available in the Defect Manager for Windows (client version) of the product.

Select the issue
you would like to
work on by
clicking on the
item with the
mouse.

You can also
right click on an
item and you will
be presented with
a list of action
that can be
performed on that
item.

3 Defect Manager Log g@
Fie Fiter Reports Statistcs Configuration View Help
slel el @ BEk me s o =58 s
[ <not set> | [ma | [anUsers | [anTypes | |#istatuses =l
2] | Type | yProduct | yRelease | Revision | ySummary | yComponent
3 Help Desk Release 2.0 My server is crashing after instaling XP SP2 Hardware
et Defect "7 Help Desk Release 2.0 System FCO02 s returning an error when logging ... Hardware
4 2 Project 1 Release 2.0 Backup fails with BXOD3ERRDS error when running ... badkup32.exe
% 3 <not set> NA ssssss
ik 4 <not set> NA z
% 5 Miscelaneous <not set> NA W
2% 6 Miscelaneous <not set> NA summ
E:3 Miscellaneous <not set> NA SESXXXKKKX
£ I >
Ready [Admin logged on at 01.02.2006 - 19:17:43 All open items [5] /

Figure: Issue [,og- Working with Issues

However, the Menu Bar and Toolbar provide alternative ways to launch operations for
the Windows and Web versions. You may select different filtered-views in the grid and
perform other operations by using Menu Bar or the Toolbar controls.
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You can enter a new issue-issue item by clicking on the “New Issue” button in the toolbar
(i.e., the first button) or use the menu bar: File > New Issue.

Different filters allow you to view selected subsets of issues and issues in the grid display
area of this window by selecting the filter you need using toolbar buttons or by using
Filter on the menu bar. For example you could locate work that is assigned to you by
selecting:

Filter >My Filters>My Open > Defects

The display grid for the Issue Log window will list the defects assigned to the indicated
name. If you have no assigned work, the list will be empty.

You can also use the Project Tool Bar or the Reported By Tool Bar to easily view
items by project and items that were reported by respectively. Both of these toolbars can
be viewed or hidden by checking them under the View menu item.

To select an issue item from the list on the grid, merely select it with a mouse click to
advance to the Detail Issue window to view and update the selected issue item (as shown
in the figure above).

You can also use the “View By Id” toolbar button or the View->By Id.menu item to
view a specific issue. Either selection will prompt you with a small window to enter the
desired 1d number as shown below.

View Item By Id

Enter the Id
number of the W

issue you would
like to work on ok | Cancel |

Figure: QOpen the Detail Jssue using its Id humber

After you click the Ok button, the Issue Detail window will open and you can view and
update the issue.

Detail Issue Window

The detail-issue window is broken up into two areas. The top area lists general
information about a particular issue and the bottom is a set of tabbed folders that organize
the majority of specific information for an issue.
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% Defect Number 1

mE}

File Action Chain

Knowledgebase View Help

This was CLOSED on 01/23/2006 at 12:28:51 PM. |t took 265 days to reslove.

I

B & =] & x| 4| Bl 8| 0] =|=| o & 8| 3|2
|/
———

Overview
Issue Status Summary: ]S_l,lstem FCO0Z is retuming an ermor when logging a new T T tranzaction.

Product: Help Desk % Type: W
Release: ’m Rexision: ’—
Severity: [W‘ Reported On: W _J
Fricrity: ’ﬁ Last Updated: m
Status: ’m Closed Orn: ﬁm
Entered By ’m— Entered On: lm
Description: Due On. J

Overview

Assigned To:

Component:
Targst:
Environment
Flatform:
Erwironmet:
Client Info

Reported By:

Company:

Status Line

wiork Bueue:

]Larr_l,l Routesy j Chained: |Mot Chained
|<not set> ~| Published: [Nat Published
|Hardware LJ L%J Approved By
|Unassigned j
]Windows j 05 Release: | 2000 -
|
|Halvey Fuby ﬂ _]

{Inlemal

j _J Location: | Back Office Team T 4]

Overview ]Hesolulion] History Log] CIiantHistory] Attachments] Souce Filas] System Test] UserDafinad] Bookmarks]

T

Ready

Figure: Issue Detail Wihdow -Summary

Some of the most important information fields that characterize the problem and identify
the current state of the issue-issue are shown in the figure above.

Summary — A brief description that summarizes the problem.

Product — Product name picked from a pre-defined list created and maintained by

your system administrator

Type — The type of item. This can be Defect, Enhancement, Call, Task, or

Miscellaneous.

Product Release — Product release identification picked from a pre-defined list

created and maintained by your system administrator.

Revision — This is the current revision level for the selected release. This field is

often used as the build level. .

Severity — The current Severity is expressed as a code for the severity of the issue in
a list box that allows the user to select from a pre-defined list of values when updating

this field.
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= Priority — The current Priority expressed as a code for the priority of the problem in a
list box that allows the user to select from a pre-defined list of values when updating
this field.

Status -- The current status-code for the issue-issue item in a drop-down list box that
allows the user to select from a pre-defined list of values when updating this field.

= Description — A text description of the issue or enhancement request.
= Reported On -- The date the issue was reported.

= Entered On -- The date the issue was entered.

= Last Updated -- The last time anyone updated the issue.

= Closed On -- The date the issue was resolved.

= Due On -- The on-or-before date the issue is scheduled to be resolved.

The bottom half of this window has tabbed folders that contain a wealth of information
related to the issue. A summary of the tabs that are available follows:

General Tab

This is general information about the issue. It is broken into three panels: Overview,
Environment, and Client Info.

Overview l Flesalution] Hiztary Ll:ng] Client Histor_l.J] .ﬁ.ttachmentsl Source Filesl Swstemn Test | User Defined Baokmarksl

Overview

Aszsigned T |Larr_l,l Routess ﬂ Chaired: |N|:ut Chaired

wiork Dueue: |<not set> ﬂ Published: |N|:ut Publizhed

Component: ||'|E"':|"“‘5"E ﬂ E g ) |

Target: | Unassigned ﬂ

E rvironment

Platform: |‘W'indu:uws j 05 Release: | 2000 ﬂ
E reviranmet: |

Clietit 1nfo

Reported By: |Harve_l.J Ruby ﬂ J
Compary: |Internal ﬂ J Location:  |Back Office Team j J

Figure: The General Tab oh the Issue Detail Window

Issue Info Panel

= Assigned To -- The person assigned as responsible for processing the issue-issue item
in the next processing step. Selected from a list of pre-defined user names.
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= Work Queue — The current work-step’s Work Queue name. By selecting another
Work Queue name from a list of pre-defined work queues, the issue item may be
routed to the next work step.

= Component — A name for the specific part of the product (e.g., module, sub-
assembly, etc.), project (e.g., project phase, task, etc.), process or service that is
related to the issue. It provides a way to identify the specific sub-component that the
issue or defect is related to. This field allows you to select the proper component
from a pre-defined list.

Notice the button to the right of this field, it allows you to add new component names
to the list-box when components that have not been previously involved in issue
reports.

= Approved By — The person that has approved this item to be worked on.

= Chained To — Set to “Not Chained” or shows links to other issue items that reported
the same or a highly-related problem.

= Published - Set to “Not Published” or “Published” or date-published indicating that
external descriptions for the issue item are visible in the Knowledgebase on the
Defect Manager’s website.

= Target Release — View the release identification where the resolution to this issue
item will be deployed (if appropriate).

Environment Panel

= Platform — Name of the operating system or environment related to the issue picked
from a pre-defined list created and maintained by your system administrator. When
software products are involved this refers to the software operating system
environment. When other types of products are involved, you list of operating
environments can refer to those appropriate to your industry.

= OS Release - Identification of the operating system version or operating environment
version/type that is appropriate to your industry.

= Environment — Additional information about the end user environment that will be
helpful in diagnosing and resolving the item beyond the Platform and OS Release.

Client Info Panel

= Reported By — User Name for the submitter of the issue item picked from a pre-
defined list of users (which can include customers) that is created and maintained by
your system administrator. Pressing the button to the right of the Reported By will
allow you to view all the detail contact information.

= Location — Identifier for the user’s site/organization location that submitted the issue
item picked from a pre-defined list created and maintained by your system
administrator.
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= Company — Name of the user’s company that submitted the issue item picked from a
pre-defined list created and maintained by your system administrator. Pressing the
button to the right of the Company will allow you to view all the detail company
information.

Resolution Tab

This tab is used to review the information that is required to resolve this issue. You
specify the Resolution, the Workaround (if any) and the Client Resolution.

Overview Resolution ] Histomny Ll:ng] Client Hish:nryl .-'-‘«ttachments] Source Files] Syztem Test] Uzer Defined] Baakmarks]

Rezolution

whork around

Client Fegolution

Figure: The Resolution Tab on the Issue Detail Wihdow

The Resolution is not displayed to your clients when they review their issues via the E-
Tech Support interface, only the Workaround and Client Resolution are viewable. This
allows you to record more-detailed or, perhaps, sensitive information in the Resolution
field.

History Log Tab

These are activities and notes that have been entered by your technicians that are
pertinent to the issue. It is a good practice for your technicians to add notes for all the
work that they have done on the issue or issue, so that anybody can pick up and continue
processing the issue.

For example, if the individual is reassigned to another task, you will not lose the
investigative work that has already been done. You should always document the time and
effort you have spent on resolving your client’s issues.
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Dverview] Fiesolution  History Log ] Client Histar_l,ll ﬁ.ttachments] Source Files] Spztem Test] zer Defined BDkaarks]

[¥ Show expanded view

01,/23/2006 - 12:28:51 PM Updated By Admit [Closed)

Cloged az Clozed. ™

01/22/2006 - 10:52:12 A Updated By Admin [Log Updated)

The Type haz been changed to ‘Enhancement’.

05/03/2005 - 12:50:33 PM Updated By Admin [Log Updated)

Friority changed from '<not get:' to ‘2. Severity changed from '<not set>' to "Spstem Crazh'.

05/03/2005 - 12:48:24 P Updated By Admin [Opened]

Opened with a Seventy of '<not zet:', Priority of '<nat zets', in the '<not zet:"Work Queue, Azzignes to 'Larmy Routes”

Figure: The History [,0g Tab oh the Issue Detail Window

To add notes to an issue, use the Action = Add a Note menu item.
Client History Tab

These are activities and notes that have been entered by your technicians and clients via
the ETech Support interface. Since your clients can see these comments, make sure you
technicians make appropriate comments.

Dverview] Hesu:ulutinn] Histary Log  Client Historg lAttachments] Source Files | System Test] Ilser Defined | Bookmarks

[¥ Show expanded view

0142342006 - 12:28:51 PM Updated By &dmin [Clozed)

Clozed az Clozed. ™

01/2242006 - 10:52:12 Ak Updated By &dmin (Log Updated)

The Type haz been changed to 'Enhancement’.

05,/0342005 - 12:50:33 Pk Updated By &dmin (Log Updated)

Severity changed from '<not et to "Spetem Crazh'

05,/0342005 - 12:48:24 PM Updated By Admin [0pened)

Opened with a Severity of '<not eets',

Figure: The Client History Tab on the Issue Detail Window
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To add notes to a issue use the Action = Add a Note menu item.

If you will not be using the E-Tech Support interface, you can use the
View - Customize option to hide the Client History tab from view.

Attachments Tab

You can add, remove and view attachments that are associated with an issue item. For
instance, you could save documents that contain screen captures of error messages (e.g., a
.bmp image file) sent in by your client. Likewise, the individual submitting the issue

item may have included a detailed text description of the problem as an Adobe Acrobat
(.pdf file as shown below) or Microsoft Word document (.doc) that can be attached. You
can also attach document links (URLS) to issues as well.

Dverview] Hesolution] Hiztary Log] Client History ~ Attachments l Source Filesl Syztem Test | User Defined | Bookmarks

Aftachments

Add File | Add Link Femove Wiew

Figure: The Attachments Tab on the Issue Detail Window

Clicking the Add File button, will display a file browser control that allows you to pick
the documents that you want to attach to the current issue.

Clicking the Add Link button, will display a window that allows you to enter the URL
that you want to attach to the current issue.

To View or Remove an attachment or link, it must first be selected. Once the attachment
icon is selected, press the View button to display the attachment with a viewer that is
associated with the attached file’s suffix.

Likewise, a selected attachment icon can be removed by clicking the Remove button.
Source Files Tab
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Your technicians can identify which source files (and the version) that were changed to
resolve this issue. Defect Manager has complete Microsoft Visual Source Safe support.

Dvewiew] Hesalutian] History LDQ] Client Histar}l] Attachments  Source Files l Syztem Testl LlserDeﬁned] BDkaarksl

Source Files:

File: Mame | er, | Last Action |
iugzer].bmp 4 02/01/2006...
guide.azpx 4 02/01 /2006

Check In File
Detach File

Help

Figure: The Source Files Tab on the Issue Detail Winhdow

The above form lists the file name, version number, date of the last action and a
description for the status for an issue item.

The buttons on the right-side of the form allow you to:
= Attach Files — Attach copies of computer program source code to an issue item
object.
= Get File — Display source code programs and other logic
= Check Out File — Allows you to check out a copy of a source code program managed
under Visual Source Safe so you can make modifications. While you have a source
code module checked out others on the team can view the code, but they cannot
modify it until you check it back in.
= Undo Check Out — Provides a way to unlock source code files when you do not have
any changes to apply.
= Check In File — Allows you to return modified source code to Visual Source Safe.
= Detach File — Allows you to delete an attached copy of a source code file

System Test Tab

Your System Test department can use this tab to log typical system test information
related to this issue. You can even import issue reports from other regression testing
tools.
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New
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Dverview] Flesalutian] Hiztary Ll:ng] I:IientHistDr_l.J] Aitachments | Source Fileg\ Svadem Test serDeﬁned] Bl:n:nkmarks]

Test Caze Results

st Name: [TEST 5vS REG 02 ~| e¢|i8| Bl X

Test Case: [ TEST-SvS-REG-02-TC03 ~| BB x|
Test Action: |Select File- M e rneru iterm ﬂ .ﬁld"| ‘i%| | b4 |
Fun By |.Jim H. Boss ﬂ

Charted: |I2I2x'EI1 A2006 - 03:46:20 AM J

Failure Code: ||

Carnmetts:

Figure: The System Test Tab on the Issue Detail Window

Each system test case related to an issue-item object has the following properties that can
be viewed and entered on this form:

Test Name — Test Names can be viewed and entered by picking from a pre-defined
list of QA Test names in this field. The tools buttons to the right of this field allow
you to: View, Add, Modify and Delete tests. When a new QA test is created with the
Add-Tool button, it is added to the pre-defined list of values for this field.

Test Case — Test Cases can be viewed and entered by picking from a pre-defined list
of QA test cases in this field. The tools buttons to the right of this field allow you to:
View, Add, Modify and Delete test cases. When a new QA test case is created with
the Add-Tool button, it is added to the pre-defined list of values for this field.

Test Action — Test Action Names can be viewed and entered by picking from a pre-
defined list of QA test action names in this field. The tools buttons to the right of this
field allow you to: View, Add, Modify and Delete test action names. When a new
QA test action name is created with the Add-Tool button, it is added to the pre-
defined list of values for this field.

Run By — The user’s name that ran the system text is picked from a pre-defined list
created and maintained by your system administrator.

WN-31
© Copyright 1999-2006 Defect Manager, Inc. All rights reserved.



. _ Tiera
Defect Manager 4.5 User Guide — Defect Manager for Windows EERTTRATS

= Started — The date and time the system test was started can be viewed and entered in
this field by using the date and time controls.

= Failure Code - This field allows you to, optionally, record a system test failure or
exception conditions and a description of their cause

= Comments — You may enter additional comments and observations in this field.
User-Defined Fields Tab

User-defined fields allow you to extend Defect Manager to better meet your
organization’s needs. These fields are defined by the Administrator to hold additional
information specific to your organization and needed by your business processes.

Your system administrator can create up to eight (8) user-defined fields of information
that are associated with each issue item.

You can also change the label on this tab from User Defined to what ever suits your
company. Sethe Administration Guide for more information on defining these fields.

Dverview] Hesu:ulutiu:un] Higtamy Log] Clisnt History] Attachments] Source Filesl System Test  User Defined I Bu:uokmarks]

Uzer Defined Fields
Ezt. [hrs): |W-‘*\ Screen ID: |

Figure: The User Defined Fields Tab on the Issue Detail Wihdow
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Bookmarks Tab

These are words that can be used by all users to easily find related issue items that are
associated with a bookmark name.

Elvewiew] Flesalutian] Hiztary Ll:ng] I:IientHistDr_l.J] Aitachments | Source Files | System Test | User Defined  Bookmarks

Bookmarks

FCO02
ME"W

i [ e |

TRANSACTION

Figure: The Bookmarks Tab on the Detail Issue Winhdow
Saving Issue Item Information

With the exception of the Attachments and Source Files tabs, all other changes are
temporary until you select the File->Save menu item, or press the Save toolbar button.
When you save a issue all modifications are logged by the system. You can review these
activities by selecting the Internal Activity and External Activity folders.

Attachments, Notes and Source File changes take affect immediately.

If you realize you have made a mistake when modifying either of these data items
associated with either of these folders, you can reverse your changes.
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Issue Detail Toolbar

The Issue Detail Toolbar operations are summarized in the figure below.

Send E-mail
Close Publish
Re-open Unpublish
Save Print

Report

/—{ Help
?

) ] = }_J/J q o o] ¥ s
Delete Unchain
Next Chain
Previous Attach File

Refresh Delete

Figure: Detail Issue Wihdow — Toolbar Qperations Summary

All the Issue Detail window toolbar functions plus other operations can be accessed from
the menu bar as summarized in the figure below.

Entering a New Issue

A new issue or issue is entered by pressing the New button on the toolbar or by using the
Menu Bar to select: File > New.

This opens the New Item window as show below.
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‘New Item - ]‘ O3
— Client Info
Company: |fT'I1-§IEra} _ﬂ =
Location: | Back Dffice Team -l j%j
Reparted By IEhzul:-I:u_l,I Srall d Hat
— Owerview
Summary: |
Froduck: l<r‘u:|t 2t ;‘ Tupe: IMisceIIaneaus ;‘
Releaze: |N-‘i"- ;I Revizion: I
Severity, |<nofset> | Reported Or: |02/03/2006 =
Friority: <hot get _'J &zsighed To; IInI:u:-H _:_I
wiork Queue: | <not set> -l Target: | Unassigned -
Compornent: |L|nassigned ;I = Due On: I _!
Deszcription:
— Environmerit
Platform: |N-"5"- _;I 05 Releaze: |Ma .ll
Additional 1rfo: |
— After zubmitting this ...
™ Submit &nother [~ Send E-Mail [~ &dd Bookmark [~ &dd atachment
| Submit I Cloze | Help |

Figure: Reporting a New Issue

= Company — The company that reported the issue/issue.
= Located At — The particular company location responsible for the issue or
issue/issue.
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The location/department in the company that reported the issue/issue. If your clients
are not specified at this level of granularity, just have your administrator create a
single location for each company.

» Reported By — The contact that reported the issue/issue.
= Summary — A brief description of the issue/issue.

» Product — Product name picked from a pre-defined list created and maintained by
your system administrator

= Type — The type of item. This can be Defect, Enhancement, Call, Task, or
Miscellaneous.

= Release — The Product release identification picked from a pre-defined list created
and maintained by your system administrator.

= Revision — This is the current revision level for the selected release. This field is
often used as the build level. .

= Severity — Select the severity of the issue/issue.

= Priority — Select the priority of this issue/issue.

= Reported On — The date this issue/issue was reported.

= Work Queue — Select the work queue where this issue/issue should be placed.
= Assigned To — Select the user who this issue/issue should be assigned to.

= Target Release — Optionally, you can select the product release that this issue/issue
will be fixed in.

= Component — Optionally, you can select the component area that this issue/issue is
related to.

= Due On -- Select the date this issue/issue needs to be resolved by.

= Description — Enter the description that describes this issue/issue. If you want to add
additional notes to the issue/issue as you proceed in resolving this, use the Action
—>Add a Note menu item in the Issue Detail window.

= Platform — Name of the operating system or environment related to the issue picked
from a pre-defined list created and maintained by your system administrator. When
software products are involved this refers to the software operating system
environment. When other types of products are involved, you list of operating
environments can refer to those appropriate to your industry.

= OS Release - Identification of the operating system version or operating environment
version/type that is appropriate to your industry.

= Environment — Additional information about the end user environment that will be
helpful in diagnosing and resolving the item beyond the Platform and OS Release.

After submitting this...
= Submit Another — Check this box if you want to enter more than one issue.
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= Send E-mail — Check this box if you want to send an e-mail about this issue to
another person.

= Add Bookmark — Check this box if you want to specify bookmarks for this item.
= Add Attachment — Check this box if you want to add an attachment to this item.

Click the Submit button to log the issue into the system. After the item has been
successfully received by the system, the Id of the item will be displayed.

If Submit Another is checked, the window will remain open for you to submit more
issue, otherwise the window will close.

If you have specified e-mail form letters, or alerts, they will automatically be sent to you
your client and users respectively. See Administration Guide for information on how to
configure this.

You can close the window at any time by clicking the Close button.

Reviewing Assigned Work from a Work Queue

Choosing the filter, File >Standard Filters—> All Open Items By Work Queue, causes
the following window to appear — it allows you select one of your assigned work queues.

-,

Filter Open For Work Queue

Select the Work, Queue you would like to review.

<rak zets j
] | Cancel |

Figsure: Viewing Assigned Work by Work Queue

Pressing the OK button will update the Issue Log with a list of all the open items in the
selected work.

Adding Notes to the History Log

The History Log automatically keeps a chronological record of all activities performed an
issue. There will be times when you want to add your own notes or comments about an
issue to the item. Selecting the Action ->Add a Note menu item will open the following
window.
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Add Notes “

Higtory Log Mote

Arything entered here will be placed in the Higtary Log.

Client Higtary Log Mote

Arything entered here will be placed in the Client History Log and wvizible to vour clients through the E-Tech
Support web interface.

[ E-mail thiz note ta the person that reported this

Add Mate | Cancel J Help

Figure: Adding Notes to the History [,ogs

There are two enterable fields on this window. They are the History Log Note and the
Client History Log Note. The History Log Note field is for you to add comments to the
History Log. These notes are internal to your company. The Client History Log Note
field is for you to add comments to the Client History Log. These notes are visible to
your clients through the E-Tech Support web interface.

If you are not planning on using the E-Tech Support interface, then you can leave the
Client History Log Note field blank. After you have entered your comments, push the
Add Note button to save your notes.

Adding Attachments and Links (URLS)

Defect Manager allows you attach an unlimited number of documents or links to an issue
item. There are many reasons why you might want to do this, here are just a couple.

e It is more accurate and simpler to attach the original information than to re-key
the information. Pictures “speak a thousand words” and original artifacts can
better articulate the problem at hand.
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e When opening a new issue, your management, technicians, or clients may want to
attach relevant error screens or additional documentation that would be helpful in
solving the problem. Pictures speak a thousand words and original artifacts can
better articulate the problem at hand.

e When implementing enhancements or, design notes, customer comments, could
be attached to the issue, so the information would not have to be re-entered into
the issue.

e Attached information is unlikely to get separated from the issue item and lost. .
You can attach a document to a issue when:

e You open a new issue as part of the New Issue window.

e Your client opens a issue via the web interface.

e When reviewing the issue after it has been opened using the
Action > Attachment menu item, or pressing the Add button in the Attachments
folder, or dropping in a file from Windows Explorer.

e Pressing the Add File button in the Attachments folder.
You can attach a document link to a issue when:
e Pressing the Add Link button in the Attachments folder.

One way to add an attachment or a link, is to select the Attachments folder in the Issue
Detail window as shown below.

Dverview] Hesolution] Hiztary Log] Client History ~ Attachments l Source Filesl Syztem Testl UserDefinedl Eookmarksl

Aftachments

s
.

it A it
crogoft. comy?

arl=1112123%4k!
nbl234

&dd File &dd Link Remove Yiew

Figure: Adding an AttaChment

To add a document, press the Add File button in the Attachments folder. To add a
document link, press the Add Link button in the Attachments folder. To remove a
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document or a document link, select the document/document link and press the Remove
button. To view a document or a document link, select the item and press the View button
or double-click on the icon.

Defect Manager will log the action and the individual that performed the action in the
activity log.

When you add a document or a document link, you will see them displayed in the bottom
of the Attachments folder.

Note: You can drag and drop files from Explorer onto the Attachments folder to add
documents.
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Send E-mail Notification
If you press the Send Mail button, you will receive the following prompt.

Figure: Select Email RecCipient Type

e T

~

~SO0FTWARE

Send Mail

-,

Send Tao

.....................

" The person that reparted this issue
" Both
" Meither

o]

Cancel |

If you check any of the first three choices above, you will be presented with the following
Outlook window for you to send your email notification.

24 RE: [Call 4] - Message (Plain Text)

i Fle Edit WView Insert Format PGP Tools Actions  Help

Sl we s i all

\ | B s

=
M
Il
il
1l
11

i:idsend | b 4| 4

Inbox <inbox >

Subject:
| [fa: 4
Summary: Backup failed
Description:

Product: <not set>
Version: NA

Revision:

Prigrity: <not set>
Severity:  <not setXx
Assigned To: Inbox
Status: New

Type: Call

RE: [Call 4]

Entered By: Admin
Reported On: 01/26/2006
Due On: 01/27/2006
Chained To:

Admin

Entered On: 02/01/2006 - 06:22:09 PM

Figure: Send E-mail Notification Window (Qutlook winhdow)

This window is the standard Microsoft Outlook window. You can use all the normal
features that you would use when using Outlook.

If you have specified an e-mail signature then your e-mail signature will be appended to
the end of the message in the Outlook message window.
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Copying an Issue
There will be times when you need to copy an issue from one project to another. Defect

Manager lets you do this quite easily and provides you some options for the copy. When
you select the File - Copy menu item, the following window will be displayed.

Copy 4

— Filter
Praduct; <not zet: ﬂ Release: | M j

[ Chair thiz to the ariginal
| Keep due date from original

| [k | Cancel ‘

Figure: Copyihg an Issue Ttem

Select the Product and Release you want the current issue to be copied to and press the
OK button. Optionally you could chain this issue to the original by checking the Chain
this to the original checkbox. Checking the Keep due date from original checkbox will
carry the due date from the original to the copy.

Closing an Issue

When you have resolved an issue, you will want to close it, indicating that this issue is
resolved. When you select the Action > Close menu item, the following window will be
displayed.
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Close 4
Id Cloze Status Code Fixed In
] Cloged LJ | Unazzsigned LJ
Rezalution -

v Set external resolution to internal resalution

Clent Reszalution

[ E-mail the external rezolution ta the person that reported this

Cloze | Cancel ‘ Help

Figure: Closing ah Issue

You will need to select the Close Status Code from the list, enter the Resolution and
optionally enter the Client Resolution field, select release that this issue is fixed in, and
then press the Close button.

You select the Resolution Code from a list of values that can be tailored to the needs of
your organization by your system administrator, as shown in the example above. Your
system administrator defines the Close Status Code to be meaningful code-values within
your organization.

Notice the checkbox labeled “Email the resolution to the person that reported this
issue” is a convenient way to maintain effective communication and follow-up with your
clients.

Remember, the Client Resolution will be visible to your clients via the E-Tech Support
interface after you complete this operation.

Opening a Closed Issue

After an issue has been closed, you might realize the issue was erroneously closed, and in
fact was not resolved. To do this you will select the Action <> Re-open menu item. The
issue will now be open again. You should start working on this issue in search of the real
resolution.
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Deferring an Issue

There will be times when it is not possible to work on a issue. There can be many reasons
for this. One reason might be that you are working on a issue and it requires additional
information from the person that reported the issue. Since you cannot actively work on it
now, you can defer it until later, when the additional documentation arrives. Then you
can re-open the issue and actively pursue its resolution. When you defer and issue with
issue manager, it will no longer be visible in your work queue as an open issue. There
will be times when you want to take a more proactive role in resuming work on the issue.
With Defect Manager you can defer the issue until a particular date. At that time the issue
will magically re-appear in the open queue. To defer work on a issue until a later time use
the Action - Defer menu item.

Chaining an Issue
There will be times when you want associate one or more issues with other issues. There
can be many reasons why you link issue items by chaining:

e Multiple reports of the same issue — When one issue report is fixed, you would
want all the others reporting the same problem to be notified.

e Avoid Redundant Effort — When identical issue-items are reported by different
sources, chaining allows them to be linked together so they can be treated as one
problem to solve.

e Recognize the Impact of a issue — By chaining, you can easily see the many
different clients that are affected by the same issue.

To chain a issue to another issue, use the Chain = Chain this Issue menu item.

Chain This Item
|nformation
Chain Thiz Item To: 455
Chained &s: | Duplicate -l

| k. | Cancel |

Figure: {Jsing Chaining to Link Two issue Items

The example above shows how the current issue will be chained to issue #5 as a duplicate
after the OK button is pressed. Once an issue is chained, you can see that the item is
chained by looking at the Chained To field on the General Tab of the Detail Issue Item
form.
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You chain an issue to another issue for one of two reasons. The reasons are:
e This issue is a duplicate of another issue or,
e This issue is a dependent of another issue

When you close a root issue that has duplicates chained to it, all duplicate issues will be
closed when the root issue is closed.

You cannot close a root issue until all the dependent issues are closed first.

Advanced System Operations
This section describes additional Defect Manager operations that are available to you.

Adding Bookmarks

Assigning bookmarks to a issue is a good way to index them so they can be found later.
You can also think of bookmarks as keywords. Select the Bookmark checkbox and you
will see the following window.

L |

Select Bookmarks
Enter Bookmark. Bookmarks
| MNEW
SERVYER
Suggested Bookmarks P2
TRAMNSACTION
BACKUP
FAILED

Exizting Bookmarks

FCOoz
INSTALLIMNG

WINDDWS J

k. | Cancel | Help |

Figure: Assighing a Bookmark to ah Issue

Bookmarks can be specified from three possible sources. You can enter them yourself
based on a value that you enter (Enter Bookmark), or you can use a suggested
bookmark (Suggested Bookmark) from the suggested bookmark list, or select an
existing bookmark (Existing Bookmark) that is already defined in the system.
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Selected Bookmarks

This lists all the bookmarks that are currently associated with this issue.
Enter Bookmark

To manually enter a bookmark of your own choosing, you can enter the bookmark into
this field and press the select (=) button, to add the bookmark to the Selected
Bookmarks List.

Suggested Bookmarks

The list is created from the description of the issue. To add these bookmarks to the
Selected Bookmarks list, just select bookmarks from this list, and press the select (=)
button.

Existing Bookmark

This list is created from the list of all currently used bookmarks in the system. To move
bookmarks from this list to Selected Bookmarks list, just select bookmarks from this
list, and press the select (=) button.

Press the Save button to save your changes.

Searching With Bookmarks

When selecting the Filter > All Issues by Bookmark menu item, the following window
is displayed:

= =1

Filter By Bookmarks

Select Bookmarks

M
~ |SERVER
| TRANSACTION|

KN KN KN KN KN

I T

] | Cancel |

Figure: Finding Issues BY Bookmarks

In this window you specify the bookmark(s) that you would like to search for in existing
issues.

You can use SQL wildcards such as “?” and ‘%’ in your search term. For example, if you
are looking for all issues that have bookmarks of Windows, Windows 98, and Windows
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NT, you could use a search term of Windows%o, which would retrieve all of the issues
that begin with Windows.

You can select up to five bookmarks to search for. The bookmark fields will provide you
with the current bookmarks as known in the system. You can select any of these or
modify existing ones to add wildcards as described above.
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Using Filters
As discussed earlier, you use the Defect Manager to review a list of issues based on a
selected filter.

For example, if you chose Filter > Standard Filters=>Open Items, you would get a list
of all the open issues like the figure below.

r’ﬁf Defect Manager Log E]

File Filter Reports Statistics Configuration View Help

[iiis s eebisisis wal el clal sl

|<n0t zely _:] |NA Li ]AIIUsers LJ iAII Types L] iAIIStatuses j .
.Id ] Type J Product Release J Revision Summary J Component

a4 phoncement  spotset>  NA  Bud1L0%  Badwpfled

< I | 2]
Ready |admin logged on at 02/03/2006 - 10:45:03 AM |all open items [1] /

Figure: Viewing All Open Jssues

Now that you have a list of open item, you may choose to work on a particular one. Click
the specific item and the Issue Detail window will be displayed.

Available Issue Lists

There are many filters that are pre-defined in the system for you. You can also create
your own custom filter. Filters are broken into the following categories: My Filters,
Standard Filters and Public Filters

My Filters

The My Filters menu item shows the filters that are generated for the system for you, or
the filters that you have created. The figure below shows the choices for My Filters.
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% Defect Manager Log B@

File | Filter Reports Statistics Configuration View Help

3 MyFilters 3 My Open 3 =3
= Standard Filters » Harrys Open Items @ :&j @J |

j Public Filters 3 :;‘lu\-'blocTznldefecis for Help Desk j |AII Types ﬂ |AII Statuses LJ

|1d N:'\I tttt | Revision | summary | Component

5 ED';B;" My Past Due Ttems Build 11,230 Backup failed

Show Chain For An Item (

Admin logged on at 02/03/2006 - 10:45:03 AM All open items [1]

Figure: Menu Of Filters to SeleCt From

When you select the My Filters menu item in the Issue Log window, you will see all the
system generated filters (such as the My Open filter) as well as any custom filters that
you have created.

Standard Filters

Standard filters are filters that would be of interest to the vast majority of users. These
filters are generated by the system. By selecting the Standard Filters menu item, you
would see the choices of the following filters.

Listed below are the built-in filters that are available, and a brief description of each.
= Open Items — This filter shows all open items in the system

= Open Items By Work Queue — This filter allows mangers and technicians to view
all defects for any or their specific work queue. It allows users to get their assigned
issues to process them.

= |tems By Bookmark — This filter allows a technician/manager to find defects that
have been indexed by a bookmark. Think of bookmarks as an alternate way to index
defects by a specific keyword. All defects that get published to the knowledge base
can be found by their bookmarks.

= |tems For A Company — This filter allow a technician/manager to view all defects
for a particular client/company.

= |tems For A Company Location — This filter allows a technician/manager to view
all defects for a particular department/site location for a particular company.

= |tems Reported By — This filter allows a technician/manager to view items reported
by a specific contact.

WN-49
© Copyright 1999-2006 Defect Manager, Inc. All rights reserved.



TS
. . era
Defect Manager 4.5 User Guide — Defect Manager for Windows EsRrymal:

= Search For Search — This filter lets you search the Summary, Description,
Resolution, or Notes for a text string. You can optionally select a product or project
to narrow the search.

Public Filters

Public filters are filters that have been created by other users and have been made public
for the user community to sue.

By selecting the Public Filters menu item, you would see all the filters that are publicly
available to all users of the system.

Custom Filters

Users can create queries and save them for your exclusive use, or you can make them
public, allowing other team members to use them. Custom queries are created by
selecting the Filters>New Filter menu-item. After you create a custom filter, you can
always use it later. It will always be under the Filters=>My Filters menu. If you made it
a public filter, then other users would see it under the Filters->Public Filters menu item.

Creating Custom Queries

When the user selects the Filters =New menu-item, the following window will be
displayed:
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e

-

Custom Filter

Access
Query Mame:; ]M_I,I open defects for Help Desk, (* Private " Public
Custarn Filter Selection
[ Column Mame Operator Walue ] AND/OR
|| |Product w|lEQUALS =] |Help Desk ~ | =lleno +]
| =l]user vl|Eouals | |Admin ~ | =llano ~|
[ | |Type ~||EQueLs  w| |Defect ~ | =|lano ]
| LJ JStatus Tope LJ |EI]L|.-’-'-.LS _J |I:Ipen Defects LJ | L” LJ
| = Bl || Eanl 2 =B
| El =] £l S Sl B
| Hl =l £ S Sl =
| =j = =l S =
Sort By
| st <] | st <] | st ]

[luen Preview -

Filter By
Product EQUALS Help Dezk' AMD
zer EQUALS ‘Admin' AMD
Type EQUALS Tefect’ AWND
Statuz Tupe EQUALS 'Open Defects’

Test | (] | Cancel ‘ Help

Figure: Defining a Custom Query to DefecCt Mahager
The custom query window will allow you to create a custom query on any field in the
system, including user defined fields. Custom queries are either named, or unnamed.
Named queries are saved by the system so they can be rerun at a later date. Unnamed
queries are temporary and are only valid after the time that you create them.

Hint: All named queries can also be used to create hard copy reports.

To create a named query, just specify a name in the Query Name field. If you do not
specify a name, then the query will be an unnamed query.

Named queries can be specified as public or private. Private queries cannot be viewed by
anyone other than the user that created the query. All users in the system can view public
queries.

To create a query, the user starts selecting the specific criteria for the custom query by
selecting the Columns Name, Operator, and Value fields. When the user selects certain
columns such as date fields, there will be an additional push button to the right of the
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Value field. Pressing this button will assist the user in selecting the value for the Value
field.

The user can also choose to use parenthesis to specify the order of evaluation for each
expression in the query. Each expression in the query, must be connected through a
Boolean operator such as AND or OR. The user can employ a drop down list containing
AND/OR to specify this relationship. As the user works with the query-builder dialog
selecting different fields that are to be part of the query, the system generates the query
syntax and the query text is displayed in the Query Preview box.

Additionally, the user can select a list of sort fields that will be used when executing the
query. Each sort field can be specified in ascending order (ASC), or descending (DESC)
order.

After the user selects all the different criteria for a custom query, a press of the Test
button will show how many issues match the query.

When the user is satisfied with the query, a press the OK button saves the query, or press
Cancel to discard the query. After pressing the OK button, the Defect Manager main
window, will be updated displaying all the issues that match the custom query that has
just been created.

Running Custom Queries

To run a custom filter, you can select it from the Filter->My Filters or the
Filter->Public Filters menu item. If there are more than 20 filters available, the last
menu item will be named More... If you select this menu item, you will see all the filters
defined to the system as show below.
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Edit Query
Filter

* Show my queries " Shaw public queries " Show all queries

Filter List

Cuery Name | Created By ] Created On ] Aocess
lazt updated Admin 1202006 - 08:17F09 Private

Filter Prewvigw

Filter By
yLazt Updated Date EQUALS 12,07, 2008

0k, | Remove ‘ Cancel

Figure: Selecting a Filter

Once this window is displayed, the user selects the query they would like to run. The
following fields are available.

= Filter — Limit the amount of filters displayed in the Filters List . You can choose to
see only your filters, or only public filter, or all filters.

= Filters List — The list of all available queries that can be selected.
= Filter Preview — The specific selection criteria that this query is based upon.

As the user selects a filter from the Filters List , the Filter Preview window is updated
to show the specific selection criteria for the query.

After the user has selected the query that they want to run, the user presses the OK button
to run the query that they have selected, or presses the Cancel button to close the
window.
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If the user wants to delete a query that is no longer needed, a press of the Remove button
after selecting a query will remove the obsolete query. Users can only delete queries that
they have created.

Editing A Custom Filter
To edit a filter that you have previously created, select the Filter 2 Edit menu item and
the following window will be displayed.

f

Edit Query
Filter

* Bhaw my queres " Show public queries " Show all queries

Filter List

Cuery Name | Created By | Created On | Access
lazt updated Adrmin 12012006 - 08:17.09 Frivate

Filter Presigw

Filker Bu
ylLazt Updated Date EQLALS 2.0, 2008

] 4 | Remove ‘ Cancel |

Figure: Editing @ Custom Filter

Select the filter that you want to edit and press the OK button. The Edit Custom Filter
window will be displayed as shown below.
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Queny Name: Ilﬂﬂ'UFﬁE‘tEd‘] % Private " Public
— Cugtom Filker Selection
[ Column Mame Operator Walue ] AND/OR
[ =] [vLast Updated Date = [EQUaLs =] [T201 2006 A = =
| =l i) =l e B 2 2H
| =l =l =] = | =l =
| =l =] =] =l | =l =
| =l =] =l Ea = H
| =l =l =] S =l H
| =l =l =] S = H
| =l =l =l Sl =
Sort By
ﬂ st <] | st <] | st ]
— [uen Preview
Filter By
wLazt Updated Date EQUALS 12.01. 2006
Test I ak I Cancel | Help I

Figure: Editing a Custom Filter

Make the desired changes to the filter and click the OK button. Optionally you can press
the Test button to see if any items match the selection criteria.

Copying A Filter
Select the Filter =>Copy menu item. Select the filter that you want to copy and press the
OK button

Deleting a Filter

Select the Filter > Edit menu item. Select the filter that you want to delete and press the
Remove button.
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Viewing the SQL Query

As you are viewing different issue lists, it may be advantageous to create reports based on
the lists you are looking at. By choosing the View - SQL Query menu item, you can
view the SQL statement that Defect Manager used to create the list. You can then copy
the SQL query to one of your favorite reporting tools, to easily generate a report.

Choosing the View ->SQL Query menu item will display the following window.

View The Current SOL Query

SELECT "
LOGPROBLEMMNO, LOGDUEDATE, LOGOPENDATE, LOGCLOSEDATE, LOGLASTUFPDATEDDATE, LOGUNDEFERDATE. ||
LOGEUSTOMERID, LOGLOCATIONID, LOGCOWNTACTID, LOGPRODID, LOGPRODRELID, LOGPRODPLATFORMID, =
LOGPRODOPSYSID, LOG.LOGSEVERITYID, LOGSEVERITYDESC, LOGPROBLEMDESC, LOGINTERMALRESOLUTIOM,
LOGEXTERMALRESOLUTION, LOGWORKAROUMD, LOGENOWLEDGEEBASERESOLUTION,

LOGKNOWLEDGEBASEDESC, LOGPROBLEMSTATUSID, LOG.LOGOWMERID, LOG.LOGGLEUEID,

LOG. LOGPRIORITYID, LOGTARGETRELEASESTATUSID, LOGTARGETPRODUCTID, LOG.LOGCOMPOMENTID,
LOG.LOGTARGETRELID, LOGGUEUEDESC, LOGDWNEREMAIL, LOGOWMERFULLMNAME, LOGOWMNERISERMAME.,
LOGSTATUSDESE, PRODUCTNAME, PRODUCTRELEASEDESCRIFTION, PLATFORMDESCRIPTION,
PLATFORMRELEASEDESCRIFTION. LOCATIONADDRESST. LOCATIONADDRESS2, LOCATIONCITY, LOCATIOMSTATE,
COMPANYNAME , COMPANYNUMBER, LOGCHAIN, LOGPRIORITYDESC, CONTACTNAME, CONTACTEMAIL, =

ey | [E

Figure: Viewing the SQI, Query that Created a List of Jssue Items

Pressing the Copy button will copy the SQL query to the clipboard. You can now use
your favorite reporting tool and paste the SQL query into it.

Exporting Issues

There might be times when you want to export issues information from Defect Manager.
You can do this by using the File >Export option from the Defect Manager main
window. Defect Manager will export all the data that is being viewed in the Defect
Manager Log window. When you export issues, you will be presented with the window

shown below:
Export

E wpart Format

-

" Clipboard
" HhL

k. | Cancel
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Figure: Exporting Issues to Other Programs

Defect Manager can exports in several formats. You should select the format that is
appropriate for you. Defect Manager can export data in Comma Separated Values (CSV),
Windows clipboard and Extensible Markup Language (XML) formats.

If you want to be able to be able to copy and paste into Microsoft Office applications
such as Word and Excel, select the Clipboard option.

Additional information of configuring Metric and related options in the repository is
available in the Administration Guide for Defect Manager.
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System Test Information

Defect Manager can maintain all the associated test case information. Defect Manager
can maintain the Test Name, Test Case Name, Test Action, Failure Code, Comment, Run
Date, and Test Run Operator. When you select the System Test tab, the following
window is displayed.

Delete QA Test

Modify QA Test

Add A New
QA Test

View Test

Generall Hesu:uluti-:unl Internal .-'f-.ctivit_lrll External .-'f-.ctivit_l,ll .-’-'-.ttau:hmentsl Sowce File

Sydem Rest | Special | 4] » |

— Test Caze Reszultz

\
Test Mame: teatl j \%_n"lﬁlil
Test Case: test case 1 = EIEIEI
Test Action: test case 3 j EIEIEI

Run By: Mark j

Started: 24 |/f200z2 j I 1:43:41 PM ﬂ

Failure Code; return code 5

Comments: This iz a regression from the previous build. ;I

Figure: System Test Ihformatioh Form
To make it easy to enter repetitive information and keep the data consistent, Defect
Manager maintains a list of all the Test Names, Test Case Names, and Test Case Actions
in the database. Next to each of these items are four buttons.

The first button is to view more information about the item, such as the description of the
actual test, the second button is to define a new item, the third button is used to modify
the item and the fourth is to delete an item. Consequently you can assign, add, modify
and delete Test Name, Test Case Name, and Test Case Action lists from this dialog.
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In the next version of Defect Manager, you will be able to populate this data via an XML
link to the regression test provider that you use.

Publishing Issues to the Knowledgebase

After spending countless hours resolving issues that have been reported, you will want to
be able to share this knowledge with the rest of the community that uses your product.
Defect Manager makes this very easy to do. After a issue has been closed it is eligible to
be published. Once it is published, users can specify bookmarks and search the
knowledgebase for insight into their own problems. To publish a issue, you would select
the Knowledgebase = Publish To Knowledgebase menu item. When you select this
menu item, the following window will be displayed as shown below.

Publish To The Knowledgebase x|

For best resultz when publizhing ta the knowledgebaze:

1. Review each field. Thiz iz what your users will see when view izsues in the knowledgebasze.
2. Review Bookmarksz. Thiz iz how uzers can find this solution,

HIMT: v'ou can use HTHML tags in any of the fields.

— Publizhing Infarmatian

Sunnnnary:

IEver_l,ltime | start the new system it crazhes.

Arhicle (D
IKB 04004000002

Description:

Follow these steps:

[1] Select the Start-» Serendipty M ow menu item
[2] Pezs the Go button
[3] The svstemn crashes.

E Emn

R ezolution:

Clozed :I

Fublizh I Bookmarks Cancel
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Figure: Publishing an Issue to the Knowledgebase

You will be able specify the knowledgebase Summary, Article 1D, Description,
Resolution for this knowledgebase item. Since these fields will be available to all E-Tech
Support users, make sure these fields are appropriately filled out. These fields will be
displayed in a browser, so you can embed html tags in the data. Make sure that you have
the proper bookmarks defined for this item so that your client base can easily find it.

The Article ID field is automatically generated to make it unique. You can change the
Article ID to anything you like, just make sure the value is unique.

If you have published a issue and no longer want it to be published, select the
Knowledgebase > Remove From Knowledgebase menu item or the toolbar button.
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Customize the System

Pressing the Customize System Toolbar button or using the Menu Bar
View->Customize ... on the Issue-ltem Log window will present the System Settings
form with three (3) tabs:
e Settings — Allows you to change your Password, Email Signature Block, and
Auto Save Option
e Visible Columns — Allows you to determine which fields on the Detail Issue Log
form are visible or not when you use the system
e Visible Folders — Allows you to specify which tabbed folders on the Detail Issue
Item form are visible or not when you use the system
e Source Safe Tab -

Customize The Spstem x|

Settings |Visible D:ulumnsl Vizible Folders | Source Safe I

— Pazzword

—Autozawve

¥ Autornatically zave my changes made to a defect

— E-mail Signature

Mour Mame ;l
“r'our Organizations Mame

123 Any Street

AT own, FL 34787

] | Cancel | Apply |

Figure: Customize the System Form — Settings Tab
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Settings Tab

The Email Signature field allows you to enter text in a multi-line format, as shown above,
to provide a standard-block format for closing all email correspondence that you generate
with Defect Manager.

The Auto-Save option, when checked, will automatically save your changes whenever
you exit a form without canceling the update. The default setting is unchecked.

The Password panel contains a Change button that allows you to modify your password
to maintain effective security. Pressing this button displays the following form.

Change Your Paszword x|

Pleaze enter your new paszswaord.

xxxxxxxxxxxxxxx

Mew Pazsward:

Confirm Paszword:

Apply I Cancel |

Figure: Settings Tab — Chanhge Your Password Prompt

The example above shows the user entering “MyNewPassword” to establish a new
password and a second time to confirm the spelling of the password. The password text
is captured but the asterisk display protects the security of the information you are
entering. Passwords in Issue Manger are case-sensitive.
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Visible Columns Tab

Not all users are from the same industry segment or may not wish to use Defect Manager
exactly in the same way. The Visible Columns tab allows you to control what columns
the use will see when view issues in the Issue Log. You select the items you want to have
visible in the Visible Columns field as shown below.

Customize The System x|

Seftings  “izible Columnz | Wisible Fu:ulu:lersl Source Safe I

—*izible Columng—— — Hidden Caolumnz
[Due On
Ezt. [krs]
Located At
Ran On
Defect Description Furn By
Last pdated xx | Screen D
TR —— Test Case
Pricrity Test Caze Action
Praduct L4 | Test Camments
Releaze Test Failure
Feported By . | Test Hame
Statuz
Target
Whork, [ueus
k. | Cancel | Apply |

Figure: Customize the System Form —Visible Columns Tab

The Visible Columns appear in the list on the left and the Hidden Columns appear on the
right. The buttons allow you to shift fields between the Visible and Hidden lists:

e Right-Arrow (=) — Move a selected Visible Field to hide it

e Right-Double-Arrow (>>) — Move all selected Visible Fields to hide them

e Left-Arrow (<€) — Move a selected Hidden Field to make it visible

e Left-Double-Arrow (<<) — Move all selected Hidden Fields to make them visible
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Visible Folders Tab

This tab allows you to specify which tabbed folders on the Issue Detail window will be
visible and available for your use. This is a way to customize the system to fit your
personal and your organizations needs.

For example, you might not need to use the Source Files Tab (folder) that works with
source code for computer programs if your organization is not a software company or IT
organization.

If you are not using User-Defined Fields, you would not need to be bothered with seeing
this tab (folder area).

Maybe, you will never need to use the Resolution Tab, but others in your organization
will use it. You can hide it from your sight, but it will still be visible to the others.

The Visible Folders tab on the form below allows you to control this.

Customize The System EI

SEttingsl Yigible Columne  Wizible Falders | Source Safe I
—Wigible Folders——— — Hidden Folders

3

System Test
dzer Defined

<4

N E2

k. | Cancel | Apply |

Figure: Customize the System Form — Visible Folders Tab

The Visible Folders (Tabs) appear in the list on the left and the Hidden Folders (Tabs)
appear on the right.

The buttons allow you to shift fields between the Visible and Hidden lists:
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Right-Arrow (=) — Move a selected Visible Folder to hide it
Right-Double-Arrow (>>) — Move all selected Visible Folders to hide them
Left-Arrow (€) — Move a selected Hidden Folder to make it visible
Left-Double-Arrow (<<) — Move all selected Hidden Folders to make them
visible

Source Safe Tab

This tab allows you configure Defect Manager to work with program source code
managed by Visual Source Safe as you are processing issue items.

Customize The System : x|

SEttingsl YWizible Enlumnsl Yigible Folders  Source Safe |

WwABRMIMG: Yizual Sowrce Safe iz not currently enabled.

—Yizual Source Safe Databaze

—Yizual Source Safe Logon Info

Izer Mame: I

[

Fazzward: I Test Connectian

— Commonly Uzed Project Paths

Select ... |
] 4 I Cancel | Apply |

Figure: Customize the System Form — SourCe Safe Tab

The Panels on the above form:

Visual Source Safe Database — You can use the browse button to the right of this
field to browse the network directory to tell Defect Manager where the Source
Safe database files of managed source-code programs are located.

Visual Source Safe Logon — You can enter the usercode and password necessary
to access Source Safe so that Defect Manager can provide the logon for you.

Commonly Used Project Paths — A list of frequently used directory paths is
provided here for your selection.
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Issue Metrics

In order to assess the effectiveness of your team, you need to know how the issues are
distributed across the various users, project and statuses. Additionally, you will want to
know if your products/project are improving over time as you prepare to put your system
into production.

Defect Manager provides for two distinct types of statistics. They are distribution
statistics, and trend analysis.

Distribution statistics and trend analysis data can be viewed as raw data, or a graph. You
can export the data to Microsoft Excel (or any other tool that you wish to use) to perform
complex analysis of the data.

Distribution Statistics
There are three types of issue distribution data that you can view. They are.

= User Distribution — View the distribution of issues across the users of your system.

= Status Distribution — View the distribution of issues by primary-status such as open
items, closed items or deferred item.

= Product Distribution — View the distribution of items across your various products
(i.e., products, projects, processes or services).

Each type of distribution has its own menu item under the Statistics menu item. Selecting
any of these items from the menu will open the Issue Distribution window shown below.
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File Yiew Help

5l B

~ Select ]
Distribution: | Courts by User |
Product |-"'“ _*I Graph Type: |Fie Chart ‘:J
Tupe: |Defects i Enhancements ;I
~ Time Period
" For today " Forthe maonth | Febusm ;l
£ For the year _;!  Fram: 3¢
Al
Refrezh |
[rata | GTEIFII"I I
I1zer | Counts
[nbow 1
Larry A outesy 2
Sharon Stone 1
Suzan Moone 1

J Tl

Ready | Last Updated at 02:42:58 FM o

Figure: Displaying the Selected Distribution StatistiCs

The window is broken into the following areas from top to the bottom.
1. Tool Bar — It includes the Refresh button and the Export button

2. Selected Distribution Type — Allows selection of Distribution Type and the
Product to use
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3. The Distribution Date and Time Period — Allows selection of the date/time
range for the distribution analysis

4. The Distribution Data Grid — It lets you view the raw distribution data

Setting the Distribution Criteria
To get distribution statistics, Defect Manager needs the following information..

= Distribution — The exact type of distribution you are looking for.

= Product — The project this distribution is for.

Issue Type — The issue types that you are looking for.

= Graph Type — You can view the data in a Bar Chart, Bar Chart (3D), Line chart
or Gantt chart.

= Time Range

Today — Show the defect distribution for the current day.
By Month -- Show the distribution for a specific month.

By Year — Show the distribution for an entire year.

Custom — Show the distribution for a specific date range.
All — Show the distribution since the system has been in use.

Trends By Product Release

You can also perform trend analysis related to a particular product (i.e., product, project,
process or service) and it’s set of releases.

To view trend analysis, select the Statistics >Product Trend By Release menu item.
This produces the following display.
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File View Help
Bl o
Select )
Product |H'3||J Desk j Trend Type:  [Opened vs. Closed Defects By Release A
Releases Starting With:  |Felease 30 | Graph Typs: | Bar Chart (301 |
Type: |Defects % Enhancements ﬂ
Refresh
Diata ] Graph l
Releaze | Open Clozed
Releaze 3.0 ] 2
Last Updated at 02:49:45 PM Reaﬂy

Figure: Product Trends By Release Metrics — Defect Trend

To get distribution statistics, Defect Manager needs the following information..
» Product — The product this trend analysis is for.

= Releases Starting With — Releases for this product that start with a particular
value. For instance, if you have releases 1.2.3.4, 1.2.3.5, thru 1.2.3.55, then
specifying 1.2.3 for this field would give you all the release from 1.2.3.5 thru
1.2.3.55

= Type —The issue types you want for this trend analysis type.

= Graph Type - You can view the data in a Bar Chart, Bar Chart (3D), Line chart
or Gantt chart.

= Trend -The trend analysis type. The choices are:
= Opened vs. Closed Items — Show the opened versus closed items by release.

= Opened vs. Reported Items -- Show the opened versus reported items by
release.

= Percentage of Reported Items — Show the percentage of reported items by
release.

= Reported Items — Show the number of reported items by release.
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Exporting Statistical Data

There might be times when you want to export statistical data (distribution or trend data)
from Defect Manager.

You can do this with the Export button or by selecting the File > Export menu item.

Defect Manager Reports

Defect Manager gives you a powerful set of predefined reports and the ability for you to
create your own reports using a customized query statement within Defect Manager..
Whether you use predefined reports or create your own Defect Manager report, Defect
Manager will allow you to select a list or a detail presentation version of a report.

Defect Manager also allows you to preview your report before you print it.

Creating New Reports

Defect Manager gives you a powerful set of tools to define your own reports based on
any guery that you have created.

To create a new report, select the Reports =>New menu item. The following window will
be displayed.
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Create A Report

M ame: ]tES report Format: |DElEII| ﬂ Arcese |Private -
Select Figldz For The Report
Fieldz: Fieldz In Bepart:
Due On ~ ﬂ Spproved By
Enterad By [ Clignt Resalution
Entered On Clozed On
Erwviranment Compary
Est. [hrg) Component
Id Dezcription
f2B AticlelD
kB Descrption
KB Publizhed B |
¥o DHHELEA n'li il Up | Cown
— Select Quemn Far The Report
CQuery Filter

% Show my queries " Show public queries " Show all queries

Awallable Queries

Huery Mame | Created By | Created On Booes) M |
Harmz Open lkems Admin 01421 /2006 - 04:47F:04 Phd Private

My open defects for Help Desk Adrmin 02201/2006 - 11:09:20PM Private| =
Publci #1 Admin 014212006 - 04:43:19 P Public |
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Figure: New Custom Reports

You will review and complete the following panels on the Create A Report form.
Report Name

Enter the descriptive name for this report.

Format

Select the format of the report. Reports can be either tabular, list, or detail formats.
Access

You can specify this report to either be private or public. If you specify public, this report
can be seen and run by others. If you specify private, only you can see the report.
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Fields for Report

Select the fields that you want to be present in the report. The fields will be displayed in
the report in the same order they are listed here.

Filter for Report

Select the filter that you want to use for this report.
Run this report when done

Select this option if you want to run the report immediately after saving the report.

If you want to see what the report looks like before saving the report, press the Preview
button and the report will be built and displayed. Click the OK. button to save the report.

Printing a Report

You can choose to run reports that you have created, default reports created by the
system, or reports created by others that have elected to share them by making them
public. To run you reports select the Reports - My Reports menu item and you will see
a list of your reports that you can run. To run other reports in the system, select the
Reports->Public Reports menu item and select the specific report you would like to
run.

Deleting a Report

You can delete any report that you have created. To delete a report, select the Reports
> Delete menu item, select the report you want to delete and press the OK button.

Previewing a Report

When you run a report in Defect Manager, you will get a chance to see the report in the
Report Pre-viewer window as show below.
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~SO0FTWARE

— Report Viewer
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Prewviem I F'ageSetup| Sawve | Copy J Send J

All open items [1]

Id: &

Type: Enhancement

Product: «not set=

Release: MN&

Revision: Buiild 11.230

Summary:

Backup failed

Component:

Entered On: 01/26/2006 - 02:55:37 PM
Last Updated: 02/03/2006 - 10:45:31 AN
Reported By: Bobkby Small

Due On: 01272008

Note added on 02/03/2006 - 10:45:31 AM by Admin (Log Updated)

Revwizion changed from " to ‘Buiild 11.230". The Type has been changed to ‘Enhancement’.

{Attachment
Added)

The following links have been added: hitpiwoenw . microsoft.comi?ari=1112123&kn01234

Note added on 02/03/2006 - 10:34:38 AM by Admin

Note added on 02/04/2006 - 06:22:09 PIM by Admin (Log Updated)

The Type has been changed to "Call.

Figure: Report Pre-viewer Wihdow

After the report has been created you can perform the following actions from the button

bar on the top of the window:

* Print - Print the report

= Preview —View the report in Print Preview mode
= Save- Save the report to disk

= Page Setup — Set printing options

= Copy - Copy the report to the clipboard

= Send - Sent the report to another person

Using Other Reporting Tools

Defect Manager provides the following ways to access the Defect Manager issue data

from other tools. The following ways are described below.
= Using SQL from a third party tool
= Exporting issue data
= Creating SQL from the database schema
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Using SOL from a Third Party tool

At anytime you can get the SQL associated with a Defect Manager filter by selecting the
View->View SQL menu item in the Issue Log. See the section Viewing the SOL Query
section for more information. You can use the SQL query in any SQL compliant
reporting tool.

Exporting Issue Data

You can export issues associated with a Defect Manager filter by selecting the Export
menu item in the Issue Log. See the section Exporting Issue Items section for more
information. After you export the data, you can then import it into any tool that supports
the data format that you specified when exporting the data.

Creating SOL from database schema

Defect Manager uses industry standard databases such as Access, SQL Server and
Oracle. You can always create your own SQL statements to retrieve the Defect Manager
issue data.

For additional information concerning the Defect Manager database schema, see the
section: Database Model in the Programmer APl Guide. The database schema layouts
for the tables will show you the data names and structures of the repository database so
you can create your own SQL queries.

It is imperative that you do not modify any of the data. Doing so could damage the
integrity of the repository and you could cause irreversible damage.

Integration with Software Tools

For companies that are using Defect Manager to support software products or IT
applications, they can optionally access Defect Manager from within these Microsoft
development tools: Visual Studio 6.0, Visual Basic 6.0 and Visual Source Safe.

Defect Manager 4.1 Add-In for Visual Studio 6.0 and Visual Basic 6.0

The Defect Manager 4.1 Add-In component permits a software developer using
Microsoft Visual Studio to interact with Defect Manager from within the Microsoft
Interactive Development Environment (IDE). The Defect Manager 4.1 Add-In
component provides a tollbar the extends the IDE by allowing users to Report
issues/issues, review their issues (open the Defect Manager Log), change system settings
(open the Defect Manager Admijnistrator), or view Defect Manager Help.

For IT departments, software developers and support staff, this allows them to process
and track their efforts to resolve issues and issues from their primary working
environment where programs, program-level documentation and design information is
readily available.
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Adding Defect Manager To Visual C++ 6.0

Issue Manger 4.0 adds direct integration into the Microsoft product family of
development tools. This integration is through the use of a Visual Studio Add-In. The
add-in, allows you to report new issues, open the Defect Manager Log application, open
the Defect Manager Administrator application, and open the Defect Manager help
system, while you are within the Visual Studio environment.

To use the Add-In you need to:
e Register the Add-In object
e Add it to the Visual Studio environment

To register the Add-In object you must run the RegisterVVS60.bat file located in the
Visual Studio Add-In sub-directory.

To install the add-in Visual Studio 6.0, you should review the Microsoft documentation,
but to give you an idea of how easy it is, follow these steps: From within Visual Studio,

1. Select the Tool = Customize menu item.
2. Select the Add-in and Macro Files tab.

3. Press the Browse button.
4

In the File dialog, select the Visual Studio Add-In directory under the Defect
Manager home directory. This default home directory is: \Program Files\Tiera
Software\Defect Manager Release 410\Visual Studio Add-In. Select the
IssueMgrVSAddIn.dll, and press the OK button.

5. The IssueManagerVSAddIn, will be listed in the Add-in and Macro Files list
and it should be checked. If it is not checked, then check it. This will enable the
Defect Manager add-in and create the Defect Manager toolbar. To give the
toolbar a descriptive name follow the next step.

6. Select the Toolbars tab. Scroll to the bottom of the list of the toolbars. The last
toolbar will be the newly added Defect Manager toolbar. Select the last toolbar
(and check the checkbox to the left of it, if it is not already checked) and specify
the descriptive name in the Toolbar name: field, such as Defect Manager.

7. Press the Close button.

You should now see the toolbar added to the Visual Studio environment, as shown
below:
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Figure: Defect Manager Toolbar Added to the Visual Studio 6.0
Window
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The toolbar has five buttons; they are described below in the order they appear in the
toolbar:

e Settings Button — There are currently only three settings that can be specified. If you
have already used Defect Manager, then the settings below have already been set and
you probably should not need to change them. The parameters are:

e Defect Manager Home — Typically this would be \Program Files\Tiera
Software\Defect Manager Release 40\

e Defect Manager User Name — User Name
e Defect Manager User Password — Password
e Report Issue Button — Opens the Defect Manager Report A Issue window.
e Defect Manager Log Button — Opens up the Defect Manager Log.
e Defect Manager Administrator Button — Opens the Defect Manager Administrator.

e Defect Manager Help Button -- Opens the Defect Manager Help.

Adding Defect Manager To Visual Basic 6.0

To use the Add-In you need to:
e Register the Add-In object
e Add it to the Visual Studio environment

To register the Add-In object you must run the RegisterVB60.bat file located in the
Visual Studio Add-In sub-directory.

To install the add-in to Visual Basic 6.0, follow these steps:
From within Visual Basic 6.0:

1. Select the Add-In =>Add-In Manager menu item. You will see the following
window:
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by Add-In

0040 Code ‘wWizard for Stored Procedures Startup / Loaded
Package and Deployment wizard
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Description _ Load Behavior

Defect Manager Releaze 4.0VE Addin ;I .............................................
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E P
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2. Select the IssueMgrVB60AddIn.
Check the Loaded/Unloaded button.

4. Check the Load on Startup button if you want the Defect Manager Add-In toobar
to be visible everytime you start Visual Basic.

5. Press the OK button.

You should now see the toolbar added to the Visual Studio environment, as shown
below:

- Defect Manals
=

Figure: Defect Manhager Toolbar Added to the Visual BasiC 6.0
Window
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The toolbar has five buttons; they are described below in the order they appear in the
toolbar:

e Settings Button — There are currently only three settings that can be specified. If you
have already used Defect Manager, then the settings below have already been set and
you probably should not need to change them. The parameters are:

e Defect Manager Home — Typically this would be \Program Files\Tiera
Software\Defect Manager Release 40\

e Defect Manager User Name — User Name
e Defect Manager User Password — Password
e Report Issue Button — Opens the Defect Manager Report A Issue window.
e Defect Manager Log Button — Opens up the Defect Manager Log.
e Defect Manager Administrator Button — Opens the Defect Manager Administrator.

e Defect Manager Help Button -- Opens the Defect Manager Help.

Using Defect Manager 4.0 with Visual Source Safe

Defect Manager 4.1 provides the capability for a software development and support
personnel to check source code in and out as well as create a copy of selected portions of
the source code related to a reported issue or issue to include as an attachment.

As the reported issue item moves through workflow from one work queue and user to
another, the references to related source code in Visual Source Safe, attachments, system
test results and notes move with along with it as a part of a complete package of work.

At each step in the workflow, users may check related source code modules out for
processing and review -- then check the source code modules back in to Visual Source
Safe before sending the issue item forward to the next step in workflow. This process
can be repeated at different workflow steps concurrent with other development uses of
the same module — with all sharing coordinated by Visual Source Safe.
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