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About the User Guide — Defect Manager for Web

This guide describes how to use Defect Manager for Web and how the web-server
version of this product can address your issue reporting, tracking and resolution needs.

The purpose of this guide is to assist you in learning what you can do and how to do it
with Defect Manager for Web

Other Defect Manager Guides

The User Guide — Defect Manager for Windows has the following companion guides that
provide additional detail on specific topics for Defect Manager:

Getting Started Guide

Installation Guide

User Guide — Defect Manager for Windows
User Guide — E-Tech Support Guide
Administration Guide

Programmer APl Guide

Glossary

Purpose of the System

Defect Manager is an interactive software product that allows companies, large and
small, to manage the capture, tracking and resolution of defects, enhancement requests,
tasks, calls and other issues related to its products, projects, processes or services.

In fact, Defect Manager should be thought of as an “Issue Management System” since
defects and problems with products, projects, processes and services are merely a subset
of issues that may be reported, tracked and managed. Reports of issues can come from
customers as well as your staff and outside contractors. Such reports on issues may
include actual defects, perceived defects, enhancements requests, questions, requests for
action or service.

The purpose of Defect Manager is to provide tools you need to capture, track and resolve
all reported issues and defects while maintaining effective communications with
stakeholders on each issue.
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How the System Works — Using Defect Manager for Web

Issue Tracking Process

It is important to remember that every company has different goals and objectives as well
as different regulations, policies and procedures that affect how it operates.

There are many ways that you can track issues as well as different methodologies to
accomplish this. In fact, almost everyone that deals with issues will have their own
opinion or an existing business process for how this should be done.

What most companies lack is an effective tool for tracking and resolving reported issues.-
- Defect Manager is designed with the flexibility to meet your company’s need for better
control throughout the complete issue tracking lifecycle.

Although each company is different, your business processes, concepts and terminology
can be accommodated in your use of Defect Manager.

Client Communications Process

As your support staff uses Defect Manager to track and resolve issues, problems and
enhancements, it should not be working in a vacuum. Your clients, the people you serve
and support, can be an integral part of your business process as well.

Defect Manager includes configurable features that automatically reminds your staff and
communicates with your clients when significant events occur during issue-item
processing such as opening an item to begin work or closing an item when the problem is
resolved. This automated, as well as user-initiated, communication can be facilitated by
Defect Manager to send appropriately formatted emails for an issue to clients and other
stakeholders.

The Defect Manager E-Tech Support application provides a web-based application to
allow your clients to easily browse your Knowledgebase of prior problems and solutions
as well as interactively submit issues, defects and enhancement requests to you. Your
clients can also use the system to check on the status of the issues they submitted. If the
support team tells a client that they need more information, the client can add the
requested information as a note or file attachment to the issue in the Defect Manager
Repository.

Defect Manager not only improves the communication and relationships with your
clients, it makes your client your “partner” where his problems are also your problems
and you are solving them together using integrated automation — Defect Manager.
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What are Issues?

The term, Issue, refers to an object in the repository database that maintains all of the
accumulated information related to an issue that has been reported.

Thus an issue or defect that is submitted to you and entered into the repository, generates
an Issue that can be tracked and have all of the related information that describes it
associated in the repository database as a single item — a single object.

The Issue-object provides you with the convenience of being able to easily access any of
its descriptive properties and associated collections of notes, documents, pictures, testing
results to efficiently view, update and process the issue.

As you process an Issue, you can add your findings, notes, and updates to its properties
and collections that reflect your contribution to the processing of the issue — Hence, the
system is tracking your work on the issue.

When your part of the processing work is done, the Issue can be conveniently passed as a
single object containing all its properties and associated information collections,
including those you just made, to the next work step required to complete its processing.

Issues are the basic objects in the repository that allow you to track and manage reported
issues such as: defects, enhancement requests, suggestions, questions, tasks, requests for
action or service, etc. The main window, the Defect Log window, in Defect Manager
for Web provides you with many ways to query and view issues, plus it allows you to
select issues to view or process.

Issues Properties and Collections

The properties of an issue-item object are of the following types;

= ldentifying property — A field that uniquely identifies an issue allowing it to be
accessed quickly

= Coded-Value properties — Fields that accept only pre-defined code-values to insure
data consistency and make it easy for a user to select the appropriate value from a
drop-down list of values.

= Timestamp and Schedule properties — Schedule and tracking dates and time values

= Descriptive properties — text information characterizing the problem or groups of
data fields that provide additional description of an issue

A Collection is a group of files containing information related to an issue-item object
that are registered and linked in the Defect Manager Repository.
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Identifying Properties

Id Number — Whenever you create a new issue, it is automatically assigned a unique
numeric identifier. This unique identifier for an issue is disclosed at the time is is
submitted. The Id number allows fast and unambiguous query access to each issue in the
system.

Coded-Value Properties

These fields contain pre-defined code values to insure that consistent data is entered and
makes it easy for a user to select the appropriate field value from a list of values.

The use of the system is made easier because your system administrator has the ability to
add, delete and change most of the sets of coded values to make them familiar and
appropriate codes for your organization.

Issue Type —When items are logged into the system they can be classified as a particular
type of issue. Defect Manager provides five primary-issue types that can be assigned to
an issue. These issue types are:

1. Defect - Anissue that is a real problem that needs to be addressed such as a bug.

2. Enhancement/Feature Request — An issue that needs to be addressed in the
future

3. Call/Question — If you have clients that may call in with an issue or a question.
Ultimately the call/question could result in the opening of a defect, enhancement
or task depending on the nature of the item.

4. Task — Work required to be performed by an individual. It could be related to
another issue ot it could be a stand alone item that needs to be researched.

5. Other/Miscellaneous — A generic type to be used at your discretion.

Status — Defect Manager provides four (3) primary-status type values for an issue that
you control with certain built-in menu-bar operations (shown below) on the Defect-Issue
Window:

1. Open Issue New; Action=> Re-Open Defect
2. Closed Issue Action = Close Defect
3. Deferred Defect Action = Defer

The primary-status values are fixed and built-in. However within each primary-status
value, the status codes you use can be tailored to provide four (3) sets of status-code
values that meet the needs of your organization and your business process.

The status of an issue is determined by a combination of its primary status and one of its
secondary status values.
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The table, shown below, lists the default sets of status-code values for each primary-
status code. These status-code sets can be changed by adding and deleting values, from
within each group, to meet your organization’s needs.

Open Defect Closed Defect Deferred Defect Enhancement
New Bug Need System Setup Needs Evaluation
Verified As Bug Not A Bug Waiting on Client Accepted
Fix Made Documentation Error Scheduled
Fix Verified How To Revenue Related
Fix in Progress Not Reproducible Client Requested
Packaged Working As Designed Rejected
On Hold
Investigating
Client Confirm Fix

Severity — Processing severity for an issue is defined in terms of code names that indicate
the severity of a defect or importance of an issue. Severity code definitions consist of a
severity name and a numerical severity sort value. The numeric severity sort value
allows issues to be ranked in the order of its severity with zero (0) being the highest
severity with the greatest urgency for resolution.

Default priority definitions are shown below which can be customized by the Defect
Manager Administrator program to meet your organizations needs.

Severity Name Severity Sort Value
System Down 0
System Crash 100
Loss of Functionality 200
Minor Issue 300

Note: By leaving gaps in the numerical severity values assigned, it is possible at a later
time to create new levels of severity within the existing severity assignments.

Priority — Processing priority for an issue is defined in terms of code names that indicate
the severity of a defect or importance of an issue. Priority code definitions consist of a
priority name and a numerical priority sort value. The numeric priority sort value allows
issues to be ranked in the order of its priority with zero (0) being the highest priority with
the greatest urgency for resolution.

Default priority definitions are shown below which can be customized by the Defect
Manager Administrator program to meet your organizations needs.

Priority Name Priority Sort Value
1 0
2 100
WB-8
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200

Note: By leaving gaps in the numerical priority values assigned, it is possible at a later
time to create new levels of priority within the existing priority assignments.

Extensible Coded Value Sets — Defect Manager allows other types of entities to be
named and referenced with code values appropriate to your organization:

Work Queues — Meaningful names for processing steps in your organization’s
workflow process can be defined where work is held while awaiting attention and
processing. Meaningful names for work queues also assist in routing work to the next
processing step while identifying the nature of the processing at each work step.

Users — Names of workers and their profiles of permissible operations can be defined.
These user names can be chosen from a list of values for the Assigned To field that
indicates the person responsible for processing an issue.

Products — Names for the things you support in your organization such as products,
projects, processes or services.

Product Releases — Code names that describe the versions or releases for the things
you support in your organization.

Groups — Names for pairings of one or more Product Names and multiple User
Names that indicate: “the Group of Users that support the Product Name(s) listed”.
Groups provide the means for the system to provide an appropriate list of users for
you to select from when assigning an issue to an individual.

Components — Meaningful names for component elements that your organization
must support or work with that may be subdivisions of products, platforms or other
entities. The Components property and code values provide an additional level of
granularity and classification for an issue.

Platform Names — Code values that represent a physical context for an issue. Some
examples of application areas and physical context are:

o Software - Computer System Type: Windows, Macintosh, Solaris, Linux
o0 Hardware = Environment Used: Clean Room; Lab, Office, Warehouse

o Field Test > Test Group/Situation: Control Group, Placebo Group,
Random Sample

Platform Releases — Code values that represent specific versions of the physical
context. Some examples of application areas and versions of physical contexts are:

o Software =2 Windows 98, Windows 2000, Windows XP
o Hardware = Clean Room: Standard 1, Standard 2, Standard 3
0 Field Test = Test Group: 2001 Tests, 2002 Tests, 2003 Tests

WB-9
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Clients/Users, Locations, and Contacts
Your clients and users can have their location and contact information stored in the
Defect Manager’s Repository database.

Timestamp and Schedule Properties

Entered On -- The date the issue was entered.

Reported Date — The date the issue was reported

Last Updated -- The last time anyone updated the issue

Closed On -- The latest date the issue was resolved and status indicated as “Closed”.

Due On -- The latest date the issue is expected or to be resolved. The date represents
a planned “on or before” date or it reflects an urgent milestone related to the issue and
its stakeholders.

Descriptive Properties
Summary — A brief description of the issue.

Description -- A long description of an issue.

Revision -- A revision/build number associated with the product/project release.

Environment — The end user environment such as service packs, versions of system
components, etc.

Sections — The Issue-Item Form has sections that contain a wealth of information related
to an issue. The sections let you selectively view additional groups of descriptive
information as follows:

= General Section -- This is general information about the Item. This section also

includes any user defined fields that have defined by your Defect Manager System
Administrator. User-defined fields allow you to extend Defect Manager to better suit
your organizations needs. You can use up to eight (8) custom fields to hold data of a
specified type that is appropriate for your organization’s issue-processing needs.

These fields are defined by using the Configuration Manager tool. You can also
change the label that appears on this tab from within this tool. See the User defined
fields in the Administration Guide for more information on defining these fields.

History Section -- This is a log of activities that have been performed on an item
such as updating, sending of e-mails, adding attachments, etc. Users can also add
notes to an issue an they are kept in chronological order with the other activities that
have been performed on an issue

Client Section -- This tab is used to review the information that is required to resolve
this defect including a workaround until the item is officially fixed. This section also
includes the client history activity. This area holds the activities and notes that have
been entered by your technicians that are pertinent. The activity notes that should be
accessible by clients using the E-Tech Support interface, It is a good practice for

WB-10
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your technicians to add notes for all the work that they have done on a defect item, so
that anybody can pick up and continue work on the defect item, if need be.

For example, if the individual is reassigned to another task, you will not lose the
investigative work that has already been done. You should always document the time
and effort you have spent on resolving your client’s defects.

Bookmark Section — This area is used to view and maintain keywords that serve as
bookmarks that allow you and others to quickly locate an issue or multiple issues
associated with the same key-word bookmark.

Issue Collections

Collections are groups of files containing documents, digital pictures, source code, text
files, sets of test result data, etc. that are related to an issue.

Defect Manager provides the following types of collections:

Attachments — Typically attachments are documents, source code segments, digital
images of photographs or faxes, memory dumps and any other files of information
that are related to an issue. This information includes information files that were
submitted by the individual reporting the issue as well as those attached by workers
while an issue is processed.

You can add, remove and view attachments.

Attachments to an issue are logged immediately -- update is not postponed until a
Save operation. If you realize that you have made a mistake when adding an
attachment, you can reverse your change.

Notes — Notes can be added to the issue in the History section and Client History
sections to document the progress of work on each issue.

System Test — Test results in multiple files can be included as a group representing
each test done while processing an issue.

Your System Test department can log system test information related to this defect.
You can even import defect reports from other regression testing tools into this
collection.

Source Files — Your technicians can track multiple source code segments, date
accessed, version of the source code and current status code.

Source file changes made on this tab are logged immediately -- update is not
postponed until a Save operation. If you realize you have made a mistake when
modifying a Source Files collection on an issue, you can reverse your changes.
The Source Files tab is primarily for use by companies involved in tracking
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issues/defects with software products, applications and web-sites; however, it can
be applied to forms of text other than program-source code.

With the exception of the Attachments, Notes and Source Files tabs, all other changes
are temporary until you the use the Action->Save menu item, or press the Save toolbar
button, or the Save button.

When you save an issue all modifications are logged by the system. You can review
these activities by selecting the History Log section and the History Log area in the
Client History section.

Repository and Activity Log
The Defect Manager Repository is the central database for the Defect Manager system.

It organizes all of the issues and related information needed to: enter, track and resolve
issues/defects.

A key part of this repository database is the History Log that stores a record of all
activities that are done to issues while using Defect Manager.

Knowledgebase

The Knowledgebase is a separate database that is available as WEB pages over the
Internet/Extranet network by using Defect Manager or its E-Tech Support system. Only
selected issues that you decide to publish to this Web-database are available for viewing
by your support team, issue stakeholders and clients authorized to use the Defect
Manager and E-Tech Support systems.

The majority of data related to an issue (including the company that reported the issue)
are not visible when an issue is published.

Workflow and Work Queues

What is Workflow?

Workflow is a method for processing issues that typically require multiple work steps to
complete its processing and it may also involve several different groups and individuals.

Defect Manager is designed to use Workflow because the processing for reported issues
and defects is typically done in multiple work steps that often involve different groups
and individuals. Each work step, or stage of work, will have a specific group or
individual that is trained and possesses the skills to do the work required at this point in
the processing of an issue.

Workflow is a useful technigue for both large and small organizations. Workflow can be
applied to small organizations that may be a “One-Man-Band” who has many things
going on and interruptions. Defect Manager workflow can help him organize and track
the pending, in-process and resolved issues he must contend with on a daily basis to
insure the important work and tasks do not get lost in the “cracks”.

The large organization may need and use many specialists that must co-operate during
the lifecycle for a reported defect. Workflow provides an effective way to “flow” the
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work between many cooperating individuals and organizations while tracking and
helping to prevent any of the related defect item information from becoming lost.

What is a Work Queue?

As work flows between work steps and different workers, it is rarely a smoothly running
assembly line where each of the work steps are synchronized by a common “conveyer
belt” as you might imagine as running in an ideal factory.

As | am sure you are aware, processing for issues and defects is normally done by
independent groups and individuals — This typically requires that the workflow be
asynchronous because these workers are not immediately available when work arrives.

Work Queues are an effective way to allow an issue to flow to the next work step and be
held until an appropriate worker is able to process it. Work queues should have
meaningful names to make it easy to route each issue to the next work step.

Specific groups or individuals obtain issues to process from a named work queue. After
completing the appropriate processing at a work queue, the issue is then placed in the
work queue for the next step in the process. Such workflow processing continues until
the final work step is completed and the issue is deferred or closed.

The names assigned to work queues should be meaningful terms within your business
process. Work-gqueue names should reflect either the type of work performed in the work
step or the group or individual that obtains work from the work queue.

It is recommended that the names be descriptive generically, rather than using the names
of individuals who may be re-assigned. For example, use a generic description such as
“QA Tester” rather than “Bill”.

Defect Processing Steps

Issues and defects are typically reported by: your customers, the system test or QA
teams, technical support teams, help desk, sales support teams, documentation teams,
management, and system integrators. Regardless of whom the defect is reported by, it is
important that you log each and every defect. To properly address and resolve the issue it
IS important that:

e A priority level is set for the reported defect based on its severity. The most
important issues should get resolved first.

e Your staff works on the defects in priority sequence.

e All effort spent on each defect is logged. This will give you the ability to re-assign
the defect to another technician without losing the investigative work previously
performed.

e Bookmarks are associated with this defect, so others can easily find all the
relevant information related to this type of defect. This helps you to start building
a coherent knowledgebase.
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Once a defect is reported, the defect should be put into a verification queue, so that
someone can verify if this is a defect, or not. The following sections characterize the
basic process from a software issue and defect processing point of view. Other lines of
business and applications for Defect Manager will have similar considerations in their
respective contexts and environments.

Defect Verification

System Test or Technical Support specialists usually review reported defects and verify if
they are in fact a defect. If is not a defect, the client must be notified that it is not a defect
and why. If it is a defect, it must be passed to appropriate group (usually development or
support) to be fixed.

Defect Correction

Based on the type of defect, there could be any number of skilled individuals that can
correct the defect. You want to make sure that these individuals have a list of all the
defects that they are expected to fix, an associated priority in which they should be
worked on, and a scheduled date that they need to have the fix completed by. These
individuals are typically software developers, documentation writers, graphic artists and
release management engineers, etc.

As they work on the defects that are assigned to them they should keep notes on
everything they have done to make progress on the defect. After they have fixed the
defect, they need to pass it on to the group that will verify that the defect is corrected.
These fixes should also be checked into the source code control system.

Defect Correction Verification

After the fix is made it needs to be passed to the group that will verify that it has truly
been corrected. Usually, the System Test group does this work.

Defect Delivery

Usually, management (based on the client need or marketing need) determines when the
defect corrections (fixes) must be completed and when they should be targeted for
delivery.

Fixes are scheduled as a hot fix/patch into the production product, distributed as problem
notices with documentation of fixes or workarounds, or they are targeted for a particular
release in the future. The nature of fixes and how they are deployed depends on your
type of business and products that are being supported.

The fix is deployed and delivered to the client along with a notice that the issue has been
resolved. The defect is closed. A final resolution is recorded. The failing component area
is recorded.
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Workflow Example with Work Queues for each Work Step.

The following is a general example of workflow processing. The processing of reported
defects could follow this workflow for our example company as shown in the figure
below.

oog C N L
888 m Workstation
NNE forkstat
i Workstation

Communications

Internet / Extranet
Wide Area
Network

Workstation|

Issue Receiving

Y

Defect Manager Defect Manager
for Windows for Web

v Y

‘

Verification &

E-Tech Support

Routing
Work Queue
v ‘ v
Defect Correction Defect Correction Defect Correction
Work Queue A Work Queue B Work Queue C
(Development) (Maintenance) (Database)

' v

Y

Rework Correction
< Verification
Work Queue

Y

Notify
Finalization Issue Item
Work Queue /] Stakeholders
Issue Item
Re-Open

Issue Item
Figure: A Sample Workflow Sequence
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The following outline describes the example workflow process shown in the above
figure. This example begins with a report of a defect over the phone or via the internet
which initiates the following action and subsequent work steps:

= |nitial Actions:

1.

Receive the defect report and enter it into Defect Manager storing it in the
Repository.
The new issue is placed in the work queue named: Verification & Routing.

Optionally, the issue may also be assigned to a specific individual that is
responsible for processing this issue.

= Subsequent Work Steps:

1.

An assigned worker for the work queue accesses the highest priority issue from
the work queue named: Verification & Routing.

Work-Step Actions: Review the issue properties and collections for completeness
and accuracy. Determine the Next work queue that should process the issue and
if a specific user should be Assigned To work on it at the next work step.

If the issue is incomplete, defer the item while taking action to obtain the missing
elements needed — once obtained, re-activate the issue and continue.

Post-Process Actions: Send the issue to the next appropriate work step for
processing by individual(s) with appropriate skills and training by placing the
issue into the proper work queue (e.g., “Defect Corrections”). Likewise, if a
specific individual should process it, assign the individual’s name in the Assign
To field for this issue.

Assigned worker accesses the highest priority issue from the work queue named:
Defect Corrections. ( Note: The issue fetched next may or may not be the one
shown in step one above, since a higher-priority issue may take precedence)

Work-Step Actions: Review the issue properties and collections to understand the
nature of the issue or defect. Research and, attempt to, resolve the issue or
defect. Log all actions taken, attach information and materials gathered that
should be retained and update the status of the issue as appropriate.
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Post-Process Actions: Send the issue to the appropriate next work step for
processing:

= |If the issue needs additional processing by other groups/specialists, assign the
work to those individuals by placing this issue in the appropriate work queue

= |f this work-step processing is completed, then place this issue in the next
appropriate work queue: Correction Verification

3. An assigned worker accesses the highest priority issue from the appropriate one of
the three work queues named: Correction Verification.

The workflow diagram, shown above, shows three different queues that are use to
hold and provide issues to workers with different specialties in defect corrections.
One or more workers know which work queues they are assigned to use.

The Assign To field can further route the issue to a specific worker because
he/she is responsible for the issue or because he/she is best able to process it at
this time.

Work-Step Actions: Review the issue properties and collections to insure that the
issue is completed properly with all of its accumulated information accurately
logged. Verify that the correction is indeed valid and complete.

Note: In the case of a software bug and bug-fix correction, this work queue might
be called “System Test”, QA-Quality Assurance, etc. This group must plan and
test the correction to insure that it is valid, complete and can be deployed with the
planned release. In addition, work-around suggestions and solutions may be
identified to provide immediate relief from the defect until the next release can be
obtained and installed.

Post-Process Actions: Send the issue to the appropriate work step for processing:

= |f this issue does not meet the quality standards required by your business
process, update its status and route it to the appropriate work queue for re-
work.
The workflow diagram, shown above, indicates that the company’s policy is
to send re-work to the Verification & Routing work queue (shown with
connector marked RW) so the individual working this queue will be able to
verify that the issue does need re-work and assign it to an appropriate worker
to correct the problem.

= |f this issue meets the quality standards required by your business process,
place it in the work queue named: Finalization.

4. The assigned worker accesses the highest priority issue from the work queue

named: Finalization.
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Work-Step Actions: Send appropriate follow-up responses to all issue-item
stakeholders. These responses would advise of the disposition of the reported
issue or defect, plans for deployment of a solution and any work-around
suggestions or solutions that could provide immediate relief.

Review the issue to determine if it should be published to the Knowledgebase to
allow staff and customers to find previously resolved issues and defects along
with the solution.

Update the issue information required to track the finalization actions performed
in this work step.

Post-Process Actions:

= |f this issue does not meet the quality standards required by your business
process, update its status and route it to the appropriate work queue for re-
work.

= |f this issue meets the quality standards required by your business process,
update it as “closed” which removes it from workflow.

This workflow example has been kept very simple and generic to illustrate the concepts
of workflow processes and issue-tracking lifecycle built around work queues.

We designed this example to show how you can combine quality-control and defect
processing steps that are done by different individuals and to:

= |llustrate how independent steps and workers can collaborate effectively

= Emphasize that injecting quality control work steps, at the beginning and end of a
process that is done by multiple independent workers, provides checks and balances
to insure that work is ready for processing before it is assigned. Likewise, it insures
that the processed work is correct before telling your customers and stakeholders
that you have resolved the problem.

= Demonstrate that work can flow asynchronously and be accessed in priority order as
it is delivered to workers at their desktop computers.

The administrator for your installation of Defect Manager will need to define and name
the work queues that best suit your organization’s needs for processing your reported
issues and defects (see the Administration Guide).
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Basic System Operations

This section covers the basic operations needed to routinely add and process issues and
defects while using Defect Manager for Web.

A separate section, Advanced System Operations, describes the more specialized
operations.

Logon to Defect Manager for Web

You begin by logging onto the system allowing it to recognize you as a pre-defined user
and the permissions you are authorized to use. The logon window below will be
displayed.

[~ = 4
&1 Tiera Software - Internet Management Solutions - Microsoft Internet Explorer E]@
Ele Edit Vew Favorites Tools Help ;?

OBack M > \ﬂ IELI ;\] /._ ) search ‘fll'i‘Favorites 6;‘"{ = - ﬁ (3 i‘%

Address @] http:/flocalhost/dmdev/ v a B @

& LOGIN - DEFECT MANAGER

User Name: [Admin

Password: |onu
[ Remember my name and password

Forgot Password?

Copyright 1998-200% Tiera Software, Inc. All rights reserved

&] Done % Local intranet

Figure: Defect Manager [,ogon Web Page

Staff users have issues assigned to them and perform work on it as a part of the process to
resolve a problem or address an issue. Staff-users can be people who: answer support
calls, do development, manage projects, test systems, document systems, produce
graphics, manage product configurations, etc. — Anyone who is a part of your
organization’s issue resolution business process.
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Users are defined by the administrator(s) of the system who configure each user with
suitable permissions and parameters.

If you are an administrator, you will also want to read the section: Configuring Usersin
the Administration Guide to see how to add new users to the system.

If you do not know your password, contact your administrator, and they can provide you
with your User Name and Password to logon to Defect Manager.

Once you are logged on to the system you can use the Defect Manager Log display grid
to select, then view or process reported issues and defects.

Issue Log Window — Main Web Page

The main web page of Defect Manager displays a log of issues as shown in the figure
below.

| €1 Thora Saftware - Internet Managemont Solutions - Micrasoft Internet Explones =/okd

Ble ot yew Fgontes [foos e

Qe - x] (& € O sewn favrives 7 -l - b3
] he LS v B &

P ——— : " ! Confiurate

L _ S D ad I WL SE QRS

7“““ | View: Detal | Filter: owtset>» w | Al Qrleases ¥ Any Asmgree o Al Types | AlSanmes w | |_Search
Tool Bar [] Al Open tiems (3]

(] § O My sorver is crashing atec installing XP SE2

Action Bar
Issue Body I/

Status Bar l\( 2
] Admn logged on 11:30:28 AM 8 Local ntranet |

Figure: Defect Manager — Maih Web Page -Issue [,og Window
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You can use the Right-Mouse Button pop-up menu to evoke browser operations.
Unlike Defect Manager for Windows, this pop-up menu displays operations that apply to
the browser — not issues.

This is one of the few minor differences that exist between the Windows and web-based
versions of Defect Manager.

However, the Menu Bar, Tool Bar and Action Bar provide alternative ways to launch
operations for the Web.

Menu Bar

The Menu Bar provides a list of actions that the user can perform by selecting a particular
menu item. The menu bar is shown below.

Reports Statistics Configuration View Export Print Logoff

Figure: Defect Manager for Web — Main Web Page -Menu Bar
Menu items are group by related functional items. The main menu items are.

= New - Log anew issue into the system
= Filter — Filter the data based on a set of criteria. There are three classes of filters.
They are:
0 Moy Filters — These are filters that were created by you or automatically
generated by the system, to assist you in managing your issues.
o Standard Filters — These are filters that are created automatically by the
system.
0 Public Filters — These are filters that were created by other users and they
have made them publicly available to the user community.
= Reports — Create and run existing reports. There are two classes of reports. They
are:
0 My Reports — These are reports that were created by you or automatically
generated by the system, to assist you in managing your issues.
0 Public Reports — These are reports that were created by other users and
they have made them publicly available to the user community.
= Statistics — There are two types of statistics that are provided. They are
distribution statistics and trend analysis statistics.
= Configuration — Configure the system. This requires Administrative privileges.
= View - Configure your workspace environment.
= Export — Export the current list of items.
= Print - Print the current list of items.
= Help - Stat the help system.
= Logoff — Logoff the system.
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Tool Bar

The Tool Bar provides an alternative to the Menu Bar to perform certain actions. These
actions are show below.

BOral AT RAX &

72 oad e dO RS
Report An Item ’—/
Print
View An Item By Id |
Run A Report
Export Items

Refresh The Screen

Configure the System
Distribution Statistics

View My Open Items

View SQL
View Open Items By Work Queue
Customize Workspace
View Items By Bookmark
Create A New Filter
View Items Chained to An Item

Figure: Defect Manager — Main Web Page —Tool Bar
Action Bar

The Action Bar has three primary functions. They are described below.
= Action - Perform multiple actions on selected items. Such as closing or deleting
multiple items at once.
= View - Change the current view in the issue body. The issue body can be
displayed as a Grid, List or Detail.
= Filter -Filter the data based on the product/project, release/version, assignee,
issue type and status.

The Action Bar is shown below.
Action: | View:|Detal || Filter:| <not set> » || All Releases | | Any Assignee || All Types | | All Statuses w
Figure: Defect Manager — Mainh Web Page —Action Bar

Selecting An Issue

To select an issue from the list, merely select it with a mouse and left click to open the -
Issue Detail window to view and update the selected issue as shown below.
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-

@ Detail For Item (Id = 0) - Microsoft Internet Explorer = @
File Action Chain View Print Help Fa
= =T : -
2 Tt he» O L2 W2 00 =
This Defect has been OPEMED for 261 days, It has not been UPDATED in 1 day(s).
Overview
Summary: My server is crashing after installing XP SP2
Product: . HE|!:I IZ_)n_Esk_. =] Type: Defect it
Release: Release 3.0 | Revision:
Severity: | System Crash I Reported On: | 05/03/2005 E!.!*
Priority: <not set> ] Last Updated:
Status: New w Clozed On:
Entered By: Entered On:
Description; Due On: @h
Assigned To: . Larry Routes V Chained To:
Waork Queue: | <not set> :.V Published:
Component: . Hardware fadd Target Release: Llljass_ig_ne_d w
Approved By:
Est. {hrs): NSA
Screen ID:
Platform: . Windows ™ 05 Release: | 2000 ':V=
Additional Info:
[ Close ] | Copy ] [ Defer ] [ Attach File ] [ Attach Link ] | E-Mail ] [ Subscrbe ]
v]
< >
&) % | ocal intranet

Figure: Defect Mahager for Web — Issue Detail

You can also use the “View Item By Id” toolbar button or the View = By Id menu item
to view a specific issue. Either approach will prompt you with a small window that
requires you enter the desired Id of the issue you would like to view as shown below.
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Enter the Id number of the
issue that you would like
view

Figure: View the Issue- Jtem using its I1d Number

(& View - Microsof. = O3

View Item By Id

[ Ok ] [ Cancel

]

%J |ocal intranet

=

~SO0FTWARE

This will show you the Issue window where you can view and update the issue that you

specified.
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Issue Detail Window

As a separate window from the main window, you can work with multiple issues at the

same time in different Issue Detail windows. Each web-browser window holds a
different web-page.

The Issue Detail window is broken up into four distinct areas as show below.

&1 Detail For Item (Id = 0) - Microsoft Internet Explorer 3
Menu Bar g@!

Tool Bar

[ C Tt he» O R 00 =

- | This Defect has been OPENED for 260 days. It has not been UPDATED in 260 day(s).

Message Area

1 []

Overview 5]
Issue Bo d y Summary: My server is crashing after installing ¥F S5P2
Product: Help Desk W Type: Defect b
Release: .R;a‘léas;a 3.‘0 =V_ Revision: .
Severity: | System Crash v Reported On: | 05/03/2005 @!-
Prigrity: [ <not set> » Last Updated:
Status: | New ¥ Closed On;
Entered By: Entered On:
Description: Due On: By
Assigned To: [ Larry Routes v Chained To:
Work Queue: | <not set> :v Published:
Component: | Hardware v [~ Target Release: L!nassigned ]

Approved By:

Est. (hrs): NAA

Screen ID:

Platform: Windows I 05 Releage: | 2000 ™

Additional Info:

{ Close ] | Copy ] [ Diefer ] [ Attach File J { AMtach Link ] | E-Mail ] [ Subscrbe ]

4

&] Done % Local intranet

Figure: Issue-Detail Wihdow

The Menu Bar area provides a list of menu choices to manage the information for the
issue, the Tool Bar area provides an alternate means to the Menu Bar for more commonly
used functions. The Message area describes important information regarding the state of
the issue. The Issue area contains the bulk of information related to the issue. The Issue
area is broken into sections. Each section contains related information.
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The Issue area contains the following sections:

Overview

History Log

Client History

Attachment

Source Files

o g~ w D

System Test
7. Bookmarks

Each section can be either in the displayed state or the hidden state. In the displayed state,
all the information related to that section is display under the section header. In the
hidden state, only the section header is displayed. In the example below, the Overview
section is hidden. Only the header is displayed.

#] Detail For Item (Id = 0) - Microsoft Internet Explorer g@

e he» OO0 AH2 00 =

This Defect has been QOPEMED for 260 days. It has not been UPDATED in 260 day(s).

Overview =

History Log

05/03/2005 - 12:50: 20 PM Updated By Admin (Log Updated)

Severity changed from '<not set>' to 'System Crash'. Summary changed from "My server is crashuing after installing XP
SP2Z to "My server is crashing after installing XP P2,

05/03/2005 - 12:47:37 PM Updated By Admin {Opened)

Opened with a Severity of '<not set>', Priority of "<not set>', in the '<not set>' Work Queue, Assignee to ‘Larry
Routes',

&] Dore % | ocal intranet

Figure: Hidden Qverview Section-
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To switch between the displayed and hidden states, you only need to press the arrow on
the right side of the section header.

You can control the sections that will be displayed on this form by selecting
Customize-> View on the menu on the Issue Log window. This allows you to remove
sections that you never use.

Note: It is important to note that removing sections that you do not use, or hiding
sections that you do not use frequently, will significantly improve performance.

Each of the sections on this form will be discussed in the pages that follow.
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Defect Manager 4.5

Overview Section

Some of the most important information fields that characterize the issue and identify the
current state of the item are shown in the figure below.

Summary: My server is crashing after installing XP SP2
Product: <not set= w Type: Defect v
Release: A hd Revision:
Severity: System Crash w Reported On: B
Priority: <not set= ~ Last Updated:
Status: Mew W Closed On:
Entered By: Entered On:
Description: Due On: By
Assigned To: Larry Routes A Chained To:
Work Queue: <not set> » Published:
Component; Unassigned | @ Target Release: Unassigned w
Approved By:
Est. (hrs): NAA
Screen ID:
enveonwent |
Platform: MNA v 05 Release: | MA v
Additional Info:
[ Close ] [ Copy ] [ Defer ] [ Attach File ] [ Attach Link ] [ E-Mail ] [ Subscribe

Figure: Qverview Section

The Overview section fields are described below.
= Summary — A brief description that summarizes the problem.

= Product - Product name picked from a pre-defined list created and maintained by
your system administrator

= Type — The type of item. This can be Defect, Enhancement, Call, task, or
Miscellaneous.

= Product Release — Product release identification picked from a pre-defined list
created and maintained by your system administrator.

WB-28
© Copyright 1999-2006 Tiera Software, Inc. All rights reserved.



Fﬂ"_"',irf\

. Tiera
Defect Manager 4.5 User Guide — Defect Manager for Web EserTRaTe

Revision — This is the current revision level for the selected release. This field is
often used as the build level. .

Severity — The current Severity is expressed as a code for the severity of the problem
in a list box that allows the user to select from a pre-defined list of values when
updating this field.

Reported On -- The date the item was reported.

Priority — The current priority expressed as a code for the priority of the problem in a
list box that allows the user to select from a pre-defined list of values when updating
this field.

Last Updated -- The last time anyone updated the item.

Status -- The current status-code for the item in a list box that allows the user to
select from a pre-defined list of values when updating this field.

Closed On -- The date the defect was resolved.

Entered By -- The person who entered the item into the system
Entered On -- The date the item was entered.

Description — A text description of the defect or enhancement request.
Due On -- The on-or-before date the defect is scheduled to be resolved.

Assigned To -- The person assigned as responsible for processing the issue-defect
item in the next processing step. Selected from a list of pre-defined user names.

Chained To — Set to “Not Chained” or shows links to other issues that this item is
related to. Items can be chained to other as a dependent or as a duplicate.

Work Queue — The current work-step’s Work Queue name. By selecting another
Work Queue name from a list of pre-defined work queues, the issue may be routed to
the next work step.

Published — Set to “Not Published” or “Published” or date-published indicating that
external descriptions for the issue are visible in the eTech Support Knowledgebase.

Component — A name for the specific part of the product (e.g., module, sub-
assembly, etc.), project (e.g., project phase, task, etc.), process or service that is
related to the issue. It provides a way to identify the specific sub-component that the
issue or defect is related to. This field allows you to select the proper component
from a pre-defined list.

Notice the button to the right of this field, it allows you to add new component names
to the list-box when components that have not been previously involved in issue
reports.

Approved By — The person that has approved this item to be worked on.
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Target Release — View the release identification where the resolution to this issue
will be deployed (if appropriate).

Platform — Name of the operating system or environment related to the issue picked
from a pre-defined list created and maintained by your system administrator. When
software products are involved this refers to the software operating system
environment. When other types of products are involved, you list of operating
environments can refer to those appropriate to your industry.

OS Release — Identification of the operating system version or operating environment
version/type that is appropriate to your industry.

Environment — Additional information about the end user environment that will be
helpful in diagnosing and resolving the item beyond the Platform and OS Release.

Workaround — Describes the workaround to be used for this item until a final
resolution is provided.

Resolution — Describes how this issue was resolved from an internal perspective.

The following actions can be performed on the item by pressing the following buttons:

Save — Save the changes made to the item. This button is gray until a data field is
modified.

Close — Close (resolve) the item

Copy - Copy the item to another product/project.

Defer — Defer working on this item until a later date.

Attach File — Attach a file to this item

Attach Link — Attach a link (URL) to this item.

Approve - Approve this item

E-Mail — E-Mail this item to any number of individuals on your team.

Subscribe — Subscribe to all updates of this item via e-mail. These e-mails are sent
independently of the e-mail alerts that are generated by the system.

Hsitory Log Section

This selection is a collection of activities and notes that have been performed or entered
by your technicians for this item. It is a good practice for your technicians to add notes
for all the work that they have done on the issue, so that anybody can pick up and
continue processing the item if they are not available or quit.

For example, if the individual is reassigned to another task, you will not lose the
investigative work that has already been done. You should always document the time and
effort you have spent on resolving your client’s defects.
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This section contains an item each activity that has been performed on the item or note
that has been added. For each activity performed, the date, the individual that performed
the activity, and the type of activity are recorded as shown below.

History Log

01/18/2008 - 03:11:56 PM Updated By Admin (Email Sent)

From: admin@a. com
To: larry@abseco. com
Subject: RE: [Defect 0] - Please help

Larry,
What is the status of this item?
Mark

05/03/2005 - 12:50: 20 PM Updated By Admin (Log Updated)

Severity changed from '<not set>' to 'System Crash'. Summary changed from 'My server is crashuing after instaling P
SP2' to "My server is crashing after installing XP SP2'.

05/03/2005 - 12:47:37 PM Updated By Admin {Opened)

Opened with a Severity of '<not set', Priority of '<not set>', in the '<not set>' Work Queue, Assignee to ‘Larry
Routes',

Figure: History [Log Section

To add a note to an item, press the Add Note button or use the Action>Add Note menu
item.
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Client History Section

a‘ fl
/

The Client History section displays all the information that is related to the client that
reported the item as shown below.

Client History [l

Reported By: Bobby Small v| ¢
Location: Back Office Team v| g
Company: Internal v| G

Workaround

Client Resolution

History Log

05/03/2005 - 12:50:20 PM Updated By Admin {Log Updated)

Severity changed from '<not set>' to 'System Crash'. Summary changed from "My server is crashuing after installing XP
SP2' to 'My server is crashing after installing ¥P SPZ.

05032005 - 12:47:37 PM Updated By Admin (Opened)
Opened with a Severity of "<not set>',

Figure: Client History Section

The Client History section fields are described below.

Reported By — User Name for the submitter of the issue picked from a pre-defined
list of users (which can include customers) that is created and maintained by your
system administrator.

Located At — Identifier for the user’s site/organization location that submitted the

issue picked from a pre-defined list created and maintained by your system
administrator.

Company — Name of the user’s company that submitted the issue picked from a pre-
defined list created and maintained by your system administrator.

Workaround — Describes the workaround to be used for this item until a final
resolution is provided.

Resolution — Describes who this issue is resolved from the clients perspective.
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= History Log — Shows a chronological list of activities that have been performed and
notes that have been added to this item from the client’s perspective.

To add a note to an item, press the Add Note button. Press the Save button to save other
changes.

Note: The Workaround, Resolution and History Log are visible to the client via the E-
Tech Support interface.

Attachments Section

You can add, remove and view attachments that are associated with an issue.

For instance, you could save documents that contain screen captures of error messages
(e.g., a .bmp image file) sent in by your client. Likewise, the individual submitting the
issue may have included text-information related to the problem as a text file (.log file, as
shown below), a screen image (.bmp file) or a Microsoft Word document (.doc) that can
be attached, etc.

Clicking on the Add File button will display a file browser control that allows you to
pick the files you want to attach to the current issue.

Clicking on the Add Link button will display a window that allows you to enter the
URL’s you want to attach to the current issue.

After a file or link has been attached, the Attachments section will be updated as shown
below.

Attachments [

() Upgradeletmini.sgl

(O hitp:ffwww. microsoft, com

[ AddFile |[ Addlnk ][ Remove

Figure: The Attachments Section

To view an attachment, click it with your left-mouse button to display the attachment
To view a link, click it with your left-mouse button and the browser will be opened with
the selected link.
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To remove an attachment, select the radio button of the desired entry and then press the
Remove button.

Source Files Section

Your technicians can identify which source files (and the version) that were changed to
resolve this issue.

Modified Files Revision Checked In
o] UpgradeJetmini.sql 12 01/19/2006 - 11:22:55 AM
[ Check In File ] [ Femove File ]

Figure: The Source Files Section

The above form lists the file name, version number, and a date of the last action for an
issue.

The buttons on the right-side of the form allow you to:
= Check In File — Allows you to identify the revision of the source code that needs to
be checked into your Source Code Control System(SCCYS)
= Remove File — Allows you to delete a source file that was not required to resolve the
item.
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System Test Section

Your System Test department can use this tab to log typical system test information
related to this defect. You can even import defect reports from other regression testing
tools.

Delete

Modify
New
View
Syetem Test [
\ E N\

Test Mame: TEST-5¥5-SMOKE-01 | a2 | =
Test Case: TEST-5YS-SMOKE-01-TCO2 w| el A= by
Test Action: Select File-»>0pen menu item w | Ee| = by
Run By: Jed Rowe e
Run Date: 01/12/2006 By
Failure Code: FC 555
Additional Comments:

Figure: The System Test Sectioh

Each system test case related to an issue-item object has the following properties that can
be viewed and entered on this form:

Test Name — Test Names can be viewed and entered by picking from a pre-defined
list of QA Test names in this field. The tools buttons to the right of this field allow
you to: View, Add, Modify and Delete tests. When a new QA test is created with the
Add-Tool button, it is added to the pre-defined list of values for this field.

Test Case — Test Cases can be viewed and entered by picking from a pre-defined list
of QA test cases in this field. The tools buttons to the right of this field allow you to:
View, Add, Modify and Delete test cases. When a new QA test case is created with
the Add-Tool button, it is added to the pre-defined list of values for this field.

Test Action — Test Action Names can be viewed and entered by picking from a pre-
defined list of QA test action names in this field. The tools buttons to the right of this
field allow you to: View, Add, Modify and Delete test action names. When a new
QA test action name is created with the Add-Tool button, it is added to the pre-
defined list of values for this field.

WB-35
© Copyright 1999-2006 Tiera Software, Inc. All rights reserved.



poered By
. Tiera
Defect Manager 4.5 User Guide — Defect Manager for Web EserTRaTe

= Run By - The user’s name that ran the system text is picked from a pre-defined list
created and maintained by your system administrator.

= Started — The date and time the system test was started can be viewed and entered in
this field by using the date and time controls.

= Failure Code - This field allows you to, optionally, record a system test failure or
exception conditions and a description of its cause

= Comments — You may enter additional comments and observations in this field.

Bookmarks Section

These are keywords that can be used by all users to easily find related issues that are
associated with a bookmark name.

Bookmarks [l

SP2
SERVER
WINDOWS
INSTALLING

[ Add ][ Remaove ]

Figure: The Bookmarks Section
You can press the Add or Remove buttons to add and remove bookmarks for the issue

Saving Changes

With the exception of the Attachments and Source Files tabs, all other changes are
temporary until you select the File->Save menu item, or press the Save toolbar button.
When you save a defect all modifications are logged by the system. You can review
these activities by selecting the Internal Activity and External Activity folders.

Attachments, Notes and Source File changes take affect immediately.

If you realize you have made a mistake when modifying either of these data items
associated with either of these folders, you can reverse your changes.
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Issue Tool Bar Summary

The Issue Toolbar operations are described in the figure below.

S e MW O D

22 09 =
Report An Item \_‘ Print
Save Changes Unpublish Item
Re-Open An Item Publish Item
Close An Item Send E-mail
View Next Iltem Unchain this Item
View Previous Item Chain This Item
Add A Note

Refresh
Figure: Issue Detgail — Toolbar Qperations
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Entering a New Issue

A new issue is entered by pressing the Report button on the toolbar or by using the
Menu Bar to select: File > New Item. After do so, the following window will be
shown.

@ New Item - Microsoft Internet Explorer E]@
This Item Was Reported By
Company: Internal
Location: Back Office Team

£ I=
00

Reported By: | Bobby Small

Product: <not set= w Type: Defect w
Release: MA A Revision:

Summary:

Severity: <not set> w Reported On:|1/15/°2006 G
Priority: <not set> w Assigned To: | Inbox W
Work Queue: <not set » Target: |Unassigned W
Component: Unassigned | @ Due On: g
Description:

End User Environment

Platform: Linux b 05 Release: | 2000 w

Additional Info:

After logging this ...
[ submit Another L] E-mail this item [ Add Bookmark [] add Attachment

[ Log ] [ Close ]

&] Done %.J Local intranet

Figure: New Issue Web Pasge
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This activates the Issue form with a new issue object to complete by filling out the
appropriate fields, described below.

Company — The company that reported that is reporting the new issue

Located At — The specific company location that reported he issue. If your clients are
not specified at this level of granularity, just have your administrator create a single
location for each company.

Reported By — The contact that reported thi issue.

Product — Select the product that this issue was found in.

Type — Select the type of issue.

Release — Release/version of the product the issue was reported in.
Revision —The revision/build level that the item was found in.
Summary — A brief description of the issue.

Severity — Select the severity of the issue.

Priority — Select the priority of this issue.

Reported On — The date this issue was reported.
Work Queue - Select the work queue where this issue should be placed.
Assigned To — Select the user who this issue should be assigned to.
Target — Optionally, you can select the product release that this issue will be fixed in.

Component — Optionally, you can select the component area that this issue is related
to.

Due On -- Select the date this issue needs to be resolved by.
Defect Description — Enter the description that describes this issue.

Platform — Name of the operating system or environment related to the issue picked
from a pre-defined list created and maintained by your system administrator. When
software products are involved this refers to the software operating system
environment. When other types of products are involved, you list of operating
environments can refer to those appropriate to your industry.

OS Release — Identification of the operating system version or operating environment
version/type that is appropriate to your industry.

Environment — Additional information about the end user environment that will be
helpful in diagnosing and resolving the item beyond the Platform and OS Release.

If you want to enter more than one item, check the Submit Another checkbox and the
window will stay open after logging the item. If this is not selected, then the window will
close after logging the item.

If you want to add bookmarks to this item, check the Add Bookmark checkbox.
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If you want to e-mail this item to someone, check the E-mail this item checkbox.

If you want to attach an item (such as a screen image, problem report, etc.) to this item,
check the Add Attachment checkbox.

Click the Log button to log the item into the system.

After pressing the Log button, the status bar at the bottom of the window will display the
unique Id assigned to this item. If you have specified e-mail form letters, your form letter
would automatically be e-mailed to the person that reported the item. See Administration
Guide: E-Mail form Letters for information on how to configure this.

When you have completed logging new defects, click the Close button to close the
window.

Viewing Open Item By Work Queue

Choosing the filter, Filter->Standard Filters=>Open Items By Work Queue, causes
the following window to appear — it allows you select one of your assigned work queues.

@ Select Work Queue For ... - Microsoft Inter... E]@

Filter By Work Queue
Select Work Queue: | <not set= w
[ QK ] [ Cancel ]
&] Dore % Local intranet

Figure: Viewing Open Issue By Work Queue

Pressing the OK button, sets the filter for the Issue-Log web-page, and the Issue Log web
page is updated showing the open items for the work queue “<not set>".
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€] Tiera Software - Internet Management Solutions - Microsoft Internet Explorer g@
File Edit View Favorites Tools Help !';'
A ) e ;) > 2
GBack . Iﬂ @ | 2 Search . Faverites 6_“ = E ﬁ [? .A‘i
Address @:] http: /flocalhostfdmdey v ﬂ Go @ lorton Antivirus il -
Reports Statistics Configuration View Export Print Logoff
H B G Bd 9 v ¥ 49 i B
2R AT A A e 10 e
Action: V View: |List V: Filter:| <notset> v All Releazes v Any Assignee v All Types v All Statuzes v

[] All Open Items [3]

[ @ 0._My server is crashing after installing XP SP2
Product: Help Desk
Release: Release 3.0
Priority: <not set>
Severity: System Crash
Assigned: Larry Routes
Status: New
Entered On: 05/03/2005 - 12:47:37 PM
Last Updated: 01/19/2006 - 11:33:39 AM
Due On;
Work Queue: <not set>

[ § 1._System FCO02 is returning an error when logging a new TTX transaction.

Product: Help Desk

Release: Release 3.0

Priority: 2

Severity: System Crash

Assigned: Larry Routes

Status: New s
@j Admin logged on 9:07:07 PM ‘J Local intranet

Figure: Gelecting ahd Processing ah Issue in @ Work Queue

The user can now select the next issue from the work queue to work on. The use of
Work Queue and Assigned To properties allows uses and their managers to easily be
informed of workloads present for work queues and individual’s assignments.
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Adding Notes to the Activity Log
To add a note to an issue, you will need to use the Action = Add Note menu item. When
you make this selection the following window will appear.

@ Add A Note To 0 - Microsoft Internet Explorer g@

] E-mail this note to the person that reported this

[ (0] ] [ Cancel

&] Dore %J Local intranet

Figure: Adding a Note to the Activity [Log

Enter the note you would like to add in the Note field. The checkbox labeled “Email this
note to the person that reported this” provides an effective way to keep your clients
informed.
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Adding Attachments

Defect Manager allows you attach an unlimited number of documents or links to an issue.
There are many reasons why you might want to do this, here are just a few.

e It is more accurate and simpler to attach the original information than to re-key
the information. Pictures “speak a thousand words” and original artifacts can
better articulate the problem at hand.

e When opening a new defect, your management, technicians and clients may want
to attach relevant error screens or additional documentation that would be helpful
for solving the problem.

e When implementing enhancements -- requirements, design notes, customer
comments could be attached to an issue, so the information would be available to
all who process the issue and the information would not have to be obtained in
another way.

e Attached information is unlikely to get separated from the issue and lost. .
You can attach a document to an item when:

e You open a new defect as part of the New Issue window.

e Your client opens a defect via the web interface and adds an attachment.

e When reviewing the defect after it has been opened using the
Action—>Attachment menu item, or pressing the Add button in the Attachments
folder, or dropping in a file from Windows Explorer.

e Pressing the Attach File button in the Overview section of the Issue Window.

e Pressing the Add File button in the Attachments section of the Issue.

[ ]
You can attach a document link to an issue when:

e Pressing the Attach Link button in the Overview section of the Issue Detail
window.

e Pressing the Add Link button in the Attachments section of the Issue Detail.

When you view the Attachments section, you will see the following window.
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() Upgradeletmini.sgl
(O hitp:ffwww. microsoft, com
| AddFile |[ Addlrk ][ Remove |

Figure: Viewing Attachments For An Issue

To add a document, press the Add File button To add a document link, press the Add
Link button. To remove a document or a document link, select the document/document

link and press the Remove button. To view a document or a document link, click the
attachment/link and click on the item.
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Send E-mail Notification

If you press the Send E-mail button, you will see the following window.

pawersd B,

N

~SO0FTWARE

@ Send Mail - Microsoft Internet Explorer

NEX)

® Assigned To Larry Routes {(arry @abseco. com)

O Reparted By Bobby Small (bobby@abseco.com)
O Assigned To and Reparted By

() Another User | Brad Gilbert w

(O other

E-Mail Message
Subject:

RE: [Defect 0]
Message:

Id: 0

Summary: My server is crashing after installing ¥P SP2
Description:

Product: Help Desk

‘ersion: Release 3.0

Revision:

Priority: <not set>

Severity: System Crash

Assigned Tos Larry Routes

Status: New

[ oK ][ Cancel ]

iEj Done

% Local intranet

Figure: Send E-mail

Select the appropriate person you would want to send the e-mail to, optionally change the
Subject and Message field and click the OK button. The e-mail will be sent and the e-

mail will be logged into the History Log section.

If you have specified an e-mail signature, then your e-mail signature will be
automatically appended to the end of the message.
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Note: The default Subject and Message are based on configurable templates by your
System Administrator. If you want these defaults values changed you should contact

them.

WB-46
© Copyright 1999-2006 Tiera Software, Inc. All rights reserved.



Fﬂ"_"',irf\

. Tiera
Defect Manager 4.5 User Guide — Defect Manager for Web EserTRaTe

Copying an Issue

There will be times when you need to copy an issue from one project to another. Defect
Manager lets you do this quite easily and provides you some options for the copy. When
you select the Action=>Copy menu item, the following window will be displayed.

r@ Copy - Microsoft Internet Explorer E]@W

Copy This Ttem To

Product: | Help Desk W Release: | Release 3.0 W

[ chain the copy to the original
[ set the due on of the copy to the original

[OK ][ Cancel ]

&] Done %J | ocal intranet

Figure: Copying anh Issue

Select the product or project you want the current issue to be copied to and press the OK
button. Optionally you could chain this issue to the original one by checking the Chain
the copy to the original checkbox. Checking the Set the due date of the copy the same
as the original checkbox will carry the due date from the original to the copy.

Closing an Issue

When you have resolved an issue, you will want to close the issue, indicating that this
item no longer requires any more action. When you select the Action-=>Close menu item,
the following window will be displayed.

WB-47
© Copyright 1999-2006 Tiera Software, Inc. All rights reserved.



Fﬂ"_"',irf\

. Tiera
Defect Manager 4.5 User Guide — Defect Manager for Web EERTTRATS
@ Close ltem - Microsoft Internet Explorer E]@
Close Status Code: | Closed w
Fixed In Release: | Unassigned w

Resolution

Set Client Resolution to Resalution

Client Resolution

(] E-mail the Client Resolution ta the user that reported this item

[ Close ][ Cancel ]

&] Done %J | ocal intranet

Figure: Closing an Issue

You will need to select the Close Status Code from the drop-down list, enter the
Resolution, optionally enter the Client Resolution field, set the Fixed In Release drop-
down list field and then press the Close button.
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The Close Status Code can be tailored to the needs of your organization by your system
administrator, as shown in the example below. Your Administrator can defines any
Close Status codes that would be meaningful to your organization

Notice the checkbox labeled “Email the Client Resolution to the person that reported
this item” is a convenient way to maintain effective communication and follow-up with
your clients.

Remember, the Client Resolution will be visible to your clients after you competed this
operation.

Opening a Closed Issue

After an issue has been closed, you might realize the item was erroneously closed, and in
fact was not resolved. To do this you will select the Action—>Re-open menu item. The
item will now be open again.

You may begin working on this item or place it in the appropriate work queue to get the
correct specialist to find the real resolution for the item.

Deferring an Issue

There will be times when it is not possible to work on an item. There can be many
reasons for this such as:

e One reason might be that you are working on a defect and it requires additional
information from the person that reported the defect. Since you cannot actively work
on it now, you can defer it until later, when the additional documentation arrives.
Then you can re-open the defect and actively pursue its resolution. When you defer
and issue with defect manager, it will no longer be visible in your work queue as an
open defect.

e There will be times when you want to take a more proactive role in resuming work on
the defect. With Defect Manager you can defer the defect until a particular date. At
that time the defect will magically re-appear in the open queue. To defer work on a
defect until a later time use the Action = Defer menu item.

Chaining an Issue

There will be times when you want associate one or more items with other items. There
can be many reasons why you link items. When you link items, you are chaining them.
There are many reasons why you might want to chain items. Here are just a few.

e Multiple reports of the same item --.When the item is closed, you would want all
the others reporting the same problem to be notified.
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e Avoid Redundant Effort — When identical issues are reported by different sources,

chaining allows them to be linked together so they can be treated as one problem to
solve.

e Recognize the Impact of an Item — By chaining, you can easily see the many
different clients that are affected by the same item.

To chain an item to another item, use the Chain = Chain Item menu item. The
following window will be displayed.

& Chain ftom 0 - Mic.... |= ) 0J&3 |

Chain to; |614

Chain as: | Duplicate |+

[ oK ] [ Cancel

"_g Local intranet

Figure: {Jsing Chaining to Link Two Issues

The window above shows how the current issue (Id 0) will be chained to item 614 as a
duplicate. Once an item is chained, you can see that the item is chained by looking at the
Chained To field on the Overview Sectionof the Issue window.

You chain an issue to another issue for one of two reasons. The reasons are:
e This issue is a duplicate of another issue or,
e This issue is a dependent of another issue

When you close a root issue that has duplicates chained to it, all duplicate issues will be
closed when the root issue is closed.

You cannot close a root issue until all the dependent issues are closed first.
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Advanced System Operations
This section describes additional Defect Manager options that are available to you.

Adding Bookmarks

Assigning bookmarks to an item is a good way to index them so they can be found later.
You can also think of bookmarks as keywords. Press the Add button on the Bookmark
section of the Issue form and you will see the Specify Bookmarks form appear.

L 1
@ Select Bookmarks - Microsoft Internet Explorer E]@
Add Bookmarks
SP2
SERVER
WINDOWS
Suggested Bookmarks IMSTALLING
P
MY
CRASHIMG .
IRECCE
HARDWARE
2000
Existing Bookmarks
QK ] [ Cancel ]
&] Done &J | ocal intranet

Figure: Assighing a Bookmark to ah Issue

Bookmarks can be specified from three possible sources, shown on the left of the
window. You can enter them yourself based on a value that you enter (Enter
Bookmark), or you can use a suggested bookmark (Suggested Bookmark) from the
suggested bookmark list, or select an existing bookmark (Existing Bookmark) that is
already defined in the system.
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Pressing the Arrow (>) button moves your selection (on the left) to the list of bookmarks
for the current issue (on the right). Pressing the OK button, completes the Add operation
and adds the bookmarks to the system.

Selected Bookmarks

This lists all the bookmarks that are currently associated with this defect.. Any
bookmarks you add for this issue will appear in this list.

Enter Bookmark

To manually enter a bookmark of your own choosing, you can enter the bookmark into
this field and press the Arrow (>) button, to add the bookmark to the Selected
Bookmarks List.

Suggested Bookmarks

The list is created from the description of the defect. To add these bookmarks to the
Selected Bookmarks list, just select bookmarks from this list, and press the Arrow (>)
button.

Existing Bookmark

This list is created from the list of all currently used bookmarks in the system. To move
bookmarks from this list to Selected Bookmarks list, just select bookmarks from this
list, and press the Arrow (>) button.
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Searching with Bookmarks

When selecting the Filter > Standard Filters=> Items By Bookmark menu item, the
following window is displayed:

@ Filter By Bookmark - Microsoft Internet ... [Z]@

Product: | Any bl

Match Any Of These Bookmarks

INSTALLING
SERVER
WINDOWS

BLUE SCREEN %

IR

tn & W N

[ (8] ][ Cancel ]

&] Done %J Local intranet

Figure: SpecCifying Bookmarks to Find with a Query

In this window you specify the bookmark(s) that you would like to search for items that
have the specified bookmarks(s). The example (above) shows the use of four (4)
bookmarks in a search with and without wildcard characters. Press the OK button to
begin the search.

You can use SQL wildcards such as “?” and ‘%’ in your search term. For example, if you
are looking for all defects that have bookmarks of Windows, Windows 98, and Windows
NT, you could use a search term of Windows%o, which would retrieve all of the defects
that begin with Windows.

You can select up to five bookmarks to search for. The bookmark fields will provide you
with the current bookmarks as known in the system. You can select any of these or
modify existing ones to add wildcards as described above.
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Using Filters
As discussed earlier, you use the Defect Manager to review a list of issues based on a
selected filter.

For example, if you chose Filter > Standard Filters=>Open Items, you would get a list
of all the open issues like the figure below.

] Tiera Software - Internet Management Solutions - Microsoft Internet Explorer Q@
Fle Edit View Favorites Tools Help ;’f
\ . 2 : ) red -
@ Back v () Iﬂ @ (p) | p- Search 7 Favorites 6“ - v ﬁ @ ‘i‘i
- 2 =
Address | &] http:flocalhost jdmdey/ || EByco W | Morton Antivius &) -
Reports Statistics Configuration View Print Logoff I
TRPH AT AA AN & il Rae
Action: v] view:|Detai .\; Filter; | <not set> || Al Releases || Any Assignes || a1 Types || Al Statuses | [Search

[ Al Open items [3]

1 @ 0._My server is crashing after installing XP SP2
Product: Help Desk
Release: Release 3.0

Priority: <notset>

Sewerity: System Crash

Assigned: Larry Routes

Status: Mew

Entered On: 05/03/2005 - 12:47:37 PM

Last Updated: 01/18/2006 - 03;11:55 FM

Due On:

History Log

01/18/2006 - 03:11:56 PM Updated By Admin (Email Sent)

From: admin@a.com
To: larry@abseco.com
Subject: RE: [Defect 0] - Please help

Larry,
What s the status of this item?
Mark

05/03/2005 - 12:50: 20 PM Updated By Admin (Log Updated)

Severity changed from '<not set>' to 'System Crash', Summary changed from My server is crashuing after installing XP
SP2' to My server is arashing after installing XP 5P2',

05/03/2005 - 12:47:37 PM Updated By Admin (Opened)

Opened with a Severity of "<not set>', Priority of "<not set>', in the "<not set>' Work Queue, Assignee to 'Larry
Routes', o
£ ¥

&] Admin logged on 10:11:12 AM % | ocal intranet

Figure: Viewing All Open Jssues

Now that you have a list of open item, you may choose to work on a particular one. Click
the specific item and the Issue window will be displayed.

WB-54
© Copyright 1999-2006 Tiera Software, Inc. All rights reserved.



Fﬂ"_"',irf\

. Tiera
Defect Manager 4.5 User Guide — Defect Manager for Web EserTRaTe

Available Issue Lists

There are many filters that are pre-defined in the system for you. You can also create
your own custom filter. Filters are broken into the following categories: My Filters,
Standard Filters and Public Filters

My Filters

The My Filters menu item shows the filters that are generated for the system for you, or
the filters that you have created. The figure below shows the choices for My Filters.

&] Tiera Software - Internet Management Solutions - Microsoft Internet Explorer E]@
File Edit W¥iew Favorites Tools Help ﬂ'
Que- © HNEAG P oo @3- LB K @3
Address | @] http:/flocalhost/dmdev/ v a Go % Norton Antivirus gy

Filter Reports Statistics Configuration View Export Print

=W Mew Filter ...

My Filters My Open

All Types ][l Statuses v

Standard Filters My Past Due Items

when logging a new TTX transaction.

Show Chain For An Item ...
Priority:

Severity: System Crash

Assigned: Larry Routes

Status: New

Entered On: 05/03/2005 - 12:48:29 PM
Last Updated: 05/03/2005 - 12:50:33 PM
Due On:

Work Queue: <notsets

&] Admin logged on 3:32:30 PM % Local intranet

Figure: Menu of many Defect Lists to Select From

When you select the My Filters menu item you will all the system generated filters (such
as the My Open filter) as well as any custom filters that you have created.

Standard Filters

Standard filters are filters that would be of interest to the vast majority of users. These
filters are generated by the system. By selecting the Standard Filters menu item, you
would see the choices of the following filters.

Listed below are the built-in filters that are available, and a brief description of each.
= Open Items — This filter shows all open items in the system

= Open Items By Work Queue — This filter allows mangers and technicians to view
all defects for any or their specific work queue. It allows users to get their assigned
issues to process them.
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= |tems By Bookmark — This filter allows a technician/manager to find defects that
have been indexed by a bookmark. Think of bookmarks as an alternate way to index
defects by a specific keyword. All defects that get published to the knowledge base
can be found by their bookmarks.

= |tems For A Company — This filter allow a technician/manager to view all defects
for a particular client/company.

= |tems For A Company Location — This filter allows a technician/manager to view
all defects for a particular department/site location for a particular company.

= |tems Reported By — This filter allows a technician/manager to view items reported
by a specific contact.

= Search For Search — This filter lets you search the Summary, Description,
Resolution, or Notes for a text string. You can optionally select a product or project
to narrow the search.

Public Filters

Public filters are filters that have been created by other users and have been made public
for the user community to sue.

By selecting the Public Filters menu item, you would see all the filters that are publicly
available to all users of the system.

Custom Filters

Users can create queries and save them for your exclusive use, or you can make them
public, allowing other team members to use them. Custom queries are created by
selecting the Filters>New Filter menu-item. After you create a custom filter, you can
always use it later. It will always be under the Filters=>My Filters menu. If you made it
a public filter, then other users would see it under the Filters->Public Filters menu item.

Creating Custom Filters

When the user selects the Filter > New Filter menu-item, the following window will be
displayed:
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@ Create Custom Filter - Microsoft Internet Explorer E]@
Custom Filter
Filter Mame: Test all tems
Filter Access: Private |+
Filter Criteria
( Column Name Operator Value ] ANDfOR
" || Product | EQUALS * || Project 1 w W [ AND [»
+ || Release | EQUALS || MA w W[ AND (W
w || Reevision w || LIKE e ||1.42% w w
" " L " w "
W W w w ~ w
w L L w w w
W W w w ~ w
" L L L “
Sort By:
Product w | [ASC |»| , |Revision » | |ASC |»| , |Rewvision W [ASC | W
Filter By
Product EQUALS 'Project 1' AND
Release EQUALS 'MA" AND
Revision LIKE '1,42.001."
Sort By
Product (Ascending), Revision (Ascending), Revision (Ascending)

[ Test ] [ Ok ] [ Cancel

&] Dane & Local intranet

Figure: Defining a Custom Filter

The custom filter window will allow you to create a custom filter on any field in the
system, including user defined fields. Custom filters are either named, or unnamed.

Named queries are saved by the system so they can be rerun at a later date. Unnamed
queries are temporary and are only valid after the time that you create them.

Hint: All named queries can also be used to create hard copy reports.

To create a named query, just specify a name in the Filter Name field. If you do not
specify a name, then the query will be an unnamed query.

Named queries can be specified as public or private. Private queries cannot be viewed by
anyone other than the user that created the query. All users in the system can view public
queries.
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To create a query, the user starts by selecting the specific criteria for the custom query by
selecting the Columns Name, Operator, and Value fields. When the user selects certain
columns such as date fields, there will be an additional push button to the right of the
Value field. Pressing this button will assist the user in selecting the value for the Value
field.

The user can also choose to use parenthesis to specify the order of evaluation for each
expression in the query. Each expression in the query, must be connected through a
Boolean operator such as AND or OR. The user can employ a drop down list containing
AND/OR to specify this relationship. As the user works with the query-builder dialog
selecting different fields that are to be part of the query, the system generates the query
syntax and the query text is displayed in the Filter Preview box.

Additionally, the user can select a list of sort fields that will be used when executing the
query. Each sort field can be specified in ascending order (ASC), or descending (DESC)
order.

After the user selects all the different criteria for a custom query, a press of the Test
button will show how many defects match the query.

When the user is satisfied with the query, press the OK button to save the query, or press
Cancel to discard the query. After pressing the OK button, the Defect Manager main
window, will be updated displaying all the defects that match the custom query that has
just been created.
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Running Custom Filters

To run a custom filter, you can select it from the Filter->My Filters or the
Filter->Public Filters menu item. If there are more than 20 filters available, the last
menu item will be named More... If you select this menu item, you will see all the filters
defined to the system as show below.

@ Edit Query - Microsoft Internet Explorer E]@

Filter: | My Private Filters |+

Filter Name | created By | Created On | user Access
{¥) Harrys Open Items Admin 01/21/2006 - 04:47:04 PM Private

Filter By
Entered On = '01/19/2006'

[ oK ][ Remove ][ Cancel ]

@] Done & Local intranet

Figure: Selecting a Filter
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Once this window is displayed, the user selects the query they would like to run. The
following fields are available.

= Filter — Limit the amount of filters displayed in the Filters List . You can choose to
see only your filters, or only public filter, or all filters.

= Filters List — The list of all available queries that can be selected.
= Filter Preview — The specific selection criteria that this query is based upon.

As the user selects a filter from the Filters List , the Filter Preview window is updated
to show the specific selection criteria for the query.

After the user has selected the query that they want to run, the user presses the OK button
to run the query that they have selected, or presses the Cancel button to close the
window.

If the user wants to delete a query that is no longer needed, a press of the Remove button
after selecting a query will remove the obsolete query. Users can only delete queries that
they have created.

Editing A Filter

To edit a filter that you have previously created, select the Filter 2 Edit menu item and
the following window will be displayed.
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@ Edit Query - Microsoft Internet Explorer E]@

Filter: | My Private Filters |+

Filter Name | created By | Created On | user Access
{¥) Harrys Open Items Admin 01/21/2006 - 04:47:04 PM Private

Filter By
Entered On = '01/19/2006'

[ oK ][ Remove ][ Cancel ]

@] Done & Local intranet

Figure: Editing a Filter

Select the filter that you want to edit and press the OK button. The Edit Custom Filter
window will be displayed as shown below.
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&1 Edit Filter - Microsoft Internet Explorer

==X

Filter Name: Hamys Open kems

Filter Access: Private |+

( Column Name Operator
w || Entered On w || EQUIALS
v w
w “
» w
w “
» v
w “
v “

Sort By
|| ASC || .

Filter By
Entered On EQUALS '01/23/2008'

Filter Criteria

b

S B B B BRI ES

Custom Filter

Value ] ANDfOR
01/23/2006 B

AT

SHENS ===

LS B B B | B ES
LSS S B B ]

w || asc ||, w||asc |w

] [ Ok ] [ Cancel

Ej Done

& Local intranet

Figure: Editing a Custom Filter

Make the desired changes to the filter and click the OK button.

Copying A Filter

Select the Filter »>Copy menu item. Select the filter that you want to copy and press the

Ok hutton

Deleting a Filter

Select the Filter > Edit menu item. Select the filter that you want to delete and press the

Remove button.
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Viewing the SQL Query

As you are viewing different defect lists, it may be advantageous to create reports based
on the lists you are looking at. By choosing the View =SQL Query menu item, you can
view the SQL statement that Defect Manager used to create the list. You can then copy
the SQL query to one of your favorite reporting tools, to easily generate a report.

Choosing the View ->SQL Query menu item will display the following window.

@ View The Current SOL Query - Microsoft Internet Explorer E]@

SELECT LOGPROBLEMNG, LOGDUEDATE, LOGOPENDATE, LOGCLOSEDATE, LOGLASTUPDATEDDATE, -
LOGUMDEFERDATE, LOGCUSTOMERID, LOGLOCATIONID, LOGCONTACTID, LOGPRODID, LOGPRODRELID, "l
LOGPRODPLATFORMID, LOGPRODOPSYSID, LOG.LOGSEVERITYID, LOGSEVERITYDESC, LOGPROBLEMDESC,
LOGINTERMALRESOLUTION, LOGEXTERMALRESOLUTION, LOGWORKAROLUMD,

LOGKMOWLEDGEBASERESOLUTION, LOGKMOWLEDGEBASEDESC, LOGPROBLEMSTATUSID, LOG.LOGOWMERID,
LOG.LOGQUELEID, LOG.LOGPRIORITYID, LOGTARGETRELEASESTATUSID, LOGTARGETPRODUCTID,
LOG.LOGCOMPOMNENTID, LOG.LOGTARGETRELID, LOGQUEUEDESC, LOGOWNEREMAIL , LOGOWMNERFULLMAME,
LOGOWMERLISERMAME, LOGSTATUSDESC, PRODUCTMAME, PRODUCTRELEASEDESCRIPTION,
PLATFORMDESCRIFTION, PLATFORMRELEASEDESCRIFTION, LOCATIOMADDRESS 1, LOCATIOMADDRESSZ, |
LOCATIOMCITY, LOCATIOMSTATE, COMPANYMAME, COMPANYMUMEBER., LOGCHAIM, LOGPRIORITYDESC, ]

Copy ] [ QK

&] Done %.J Local intranet

Figure: Viewing the SQIL, Query that Created a List Of Issues

Pressing the Copy button will copy the SQL query to the clipboard. You can now use
your favorite reporting tool and paste the SQL query into it.

Exporting Issues Items

There might be times when you want to export items from Defect Manager. You can
export items in Microsoft Excel format or as an HTML page.

To export items to Microsoft Excel, select the Export =>Microsoft Excel menu item.

You can use Excel to manipulate, analyze and display this information in spreadsheet,
report or graphical form using the Excel tool. Excel also provides you with a wide-range
of data-interchange formats that you can use to convert the extracted file to another
format.

To export items as an HTML page, select the Export >HTML Page menu item.

Publishing Issues to the Knowledgebase

After spending countless hours resolving issue that have been reported, you will want to
be able to share this knowledge with the rest of the community that uses your product.
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Defect Manager makes this very easy to do. After an item has been closed it is eligible to
be published. Once it is published, users can search the knowledgebase for insight into
their own problems.

To be able to publish an item, the following two conditions must be met.
1. The item must be closed.
2. The user needs to have the Can Publish privilege.

If both of these conditions are met, then you select the Knowledgebase = Publish To
Knowledgebase menu item. When you select this menu item, the following window will
be displayed as shown below.

@ Publish To Knowledgebase - Microsoft Internet Explorer E]@
Publish To Knowledgebase
Summary: System FCD02 i retuming an emor when logging a new TTX transaction.
ArticeID: KBD623000001

Resolution:

[ Publish ][ Cancel

&] Done % Local intranet

Figure: Publish to the Khowledgebase

You will be able specify the Summary, Article ID, Description, and the Resolution for
the item that you are publishing. These fields will be available to all E-Tech Support
users, so make sure these fields are appropriately filled out. The published item will be
displayed in a browser, so you can embed HTML tags in these fields. Make sure that you
have the proper bookmarks defined for this item so it can easily be found.
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The Article ID field is automatically generated to make it unique, but can change the
Article ID to anything you like, just make sure the value is unique.

If you have published an item and no longer want it to be published, select the
Knowledgebase > Remove From Knowledgebase menu item, or the toolbar button.

Customize Your Workspace

To customize your workspace, press the Customize System Tool Bar button or select the
View->Customize ... menu item. The following window will be opened.

&1 Customize The System - Microsoft Internet Explorer E]@

Y

L
Ei:
g
=]
(%]

Password

[+1]
(%]
[%]

MNew password:

Confirm password:

Email Signature

Auto Save

[] Auto Save Changes

Choose Fields To Display On Home Fage

Visible Fields: Hidden Fields:
Product Component »
Release Target
Priority Closed On
Summary Company
Severity N Location
Lzer Reported By
Status Test Mame
Entered On Test Case
Last Updated Test Action
Due On E] Test Run By
Wark Queue E] Test Run Date
Test Failure Code
Test Comments
Est. (hrs)
Screen ID
Reported On
Resolution v v
&] Done %.J Local intranet

Figure: Customizing Your Workspace
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You can change the following settings in your workspace.

Password — Your password to access the system

E-Mail Signature — The Email Signature field allows you to enter text in a multi-line
format to provide a standard-block format for closing all email correspondence that you
generate with Defect Manager.

Auto Save Changes — When you make change on Issue Detail window, your changes
will automatically be saved when you browse to the next or previous item. If this option
is not set, then you have to manually press the Save button to save your changes.

Fields On The Home Page — Select which fields will be displayed on your Defect
Manager Home page.

Sections On The Issue Window — Select which sections will be displayed on the Issue
window.

After you make the appropriate changes press the OK button to save these changes.

Configuring the System

To configure the system and change settings such as priorities, users, severities, projects,
etc. select the Configuration menu item. After selecting this menu item, the
Configuration Manager window will be open as show below.

@] Configuration Manager - Microsoft Internet Explorer B@
- |

Clients System Settings -

¢ Users
£ Groups

Work Queues System Settings

B Components

Statuses

Severities Your Company Name: Your company name
Platform Names

H Platform Releases

;. Products

Attachment Falder: C:\Program Files\Tiera Software'\Defect Manager Release 450" Attachments
Starting Id For New Items:

Allow deleting items at a system level

D Use Groups

[ set send Email Option as checked

[ set Add Bookmark as checked

Date[Time Display Format

Date Format: “m/%d /Y Sample:

Time Format: S %p Sample:

Date - Time Format: [%m/%d /%Y - %l %M%S Zp Sample:

Maximum Logon Tries: 3

Web Security Level: Low v

Update

#&] Done %4 Local intranet

Figure: Configuring the System
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Statistics

In order to assess the effectiveness of your team, you need to know how the issues are
distributed across the various users, project and statuses. Additionally, you will want to
know if your products/project are improving over time as you prepare to put your system
into production.

Defect Manager provides for two distinct types of statistics. They are distribution
statistics, and trend analysis.

Distribution statistics and trend analysis data can be viewed as raw data, or a graph. You
can export the data to Microsoft Excel (or any other tool that you wish to use) to perform
complex analysis of the data.

Distribution Statistics
There are three types of issue distribution data that you can view. They are.

= User Distribution — View the distribution of issues across the users of your system.

= Status Distribution — View the distribution of issues by primary-status such as open
items, closed items or deferred item.

= Product Distribution — View the distribution of items across your various products
(i.e., products, projects, processes or services).

Each type of distribution has its own menu item under the Statistics menu item. Selecting
any of these items from the menu will open the Issue Distribution window shown below.
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&1 Distribution: Counts by User - Microsoft Internet Explorer

o D

=%

Select Distribution Type

%J | ocal intranet

Distribution: Counts by User by Status

Product:

Type: Defects and Enhancements w
Select Time Period

(¥ For Today ) For the month

O For the year O From: o Thru: B
O Al

Refresh
User IStatus |Cou nts |
Larry Routes Closed 1
Ej Dane

Figure: Displaying the Selected Distribution StatistiCs

The window is broken into the following areas from top to the bottom.
1. Tool Bar — It includes the Refresh button and the Export button

2. Selected Distribution Type — Allows selection of Distribution Type and the

Product to use
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3. The Distribution Date and Time Period — Allows selection of the date/time
range for the distribution analysis

4. The Distribution Data Grid — It lets you view the raw distribution data

Setting The Distribution Criteria
To get distribution statistics, Defect Manager needs the following information..

= Distribution — The exact type of distribution you are looking for.

= Product — The project this distribution is for.

Issue Type — The issue types that you are looking for.

= Time Range

Today — Show the defect distribution for the current day.
By Month -- Show the distribution for a specific month.

By Year — Show the distribution for an entire year.

Custom — Show the distribution for a specific date range.
All — Show the distribution since the system has been in use.

Trends By Product Release

You can also perform trend analysis related to a particular product (i.e., product, project,
process or service) and it’s set of releases.

To view trend analysis, select the Statistics >Product Trend By Release menu item.
This produces the following display.
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&1 Defect Trend By Product Release - Microsoft Internet Explorer E]@
File
Product: Project 2 w
Releases Starting With: E]
Trend: Reported Defects w
Type: Defects and Enhancements
Release IREpo-rtEd |
Build 1.2.2 1
Close
&] Done & Local intranet

Figure: Product Trends By Release MetriCs — Defect Trend

To get distribution statistics, Defect Manager needs the following information..
» Product — The product this trend analysis is for.

= Releases Starting With — Releases for this product that start with a particular
value. For instance, if you have releases 1.2.3.4, 1.2.3.5, thru 1.2.3.55, then
specifying 1.2.3 for this field would give you all the release from 1.2.3.5 thru
1.2.3.55

= Type —The issue types you want for this trend analysis type.
= Trend -The trend analysis type. The choices are:
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= Opened vs. Closed Items — Show the opened versus closed items by release.

= Opened vs. Reported Items -- Show the opened versus reported items by
release.

= Percentage of Reported Items — Show the percentage of reported items by
release.

= Reported Items — Show the number of reported items by release.

Exporting Statistical Data

There might be times when you want to export statistical data (distribution or trend data)
from Defect Manager.

You can do this with the Export button or by selecting the File > Export menu item.

Defect Manager Reports

Defect Manager gives you a powerful set of predefined reports and the ability for you to
create your own reports using a customized query statement within Defect Manager..
Whether you use predefined reports or create your own Defect Manager report, Defect
Manager will allow you to select a list or a detail presentation version of a report.

Defect Manager also allows you to preview your report before you print it.

Creating New Reports

Defect Manager gives you a powerful set of tools to define your own reports based on
any guery that you have created.

To create a new report, select the Reports =>New menu item. The following window will
be displayed.
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#] Create a Report - Microsoft Internet Explorer

New Report

Report Information

Report Mame:

Fields For Report

Fields:

Approved By
Client Resolution
Closed On
Company
Component
Defect
Description
Due On
Entered By
Entered On
Enviranment
Est. (hrs)

Select The Filter For This Report
Filters

Filter: | My Private Filters |»

=

A o ]
i b w

Format: | Tabular

Selected:

| Access:

?

[ Mowve Up ] [ Mowve Down ]

Public

e

Filter Preview

Filter I Created By I Created On | Access | i
()  Harrys Open Items Admin 01/21/2006 Private
{3 Publd #1 Admin 01/21/2006 Public
C- it Adrmin 01/21/2006 Public
{3 My Past Due Items System 01/23/2006 Private i

[ Run this report when done

Filter By Entered On = '01/19/2006'

ok ]|

Cancel

][ Preview ]

Figure: New Custom Reports

You will review and complete the following panels on the Create A Report form.

Report Name

Enter the descriptive name for this report.

Format

Select the format of the report. Reports can be either tabular, list, or detail formats.
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Access

You can specify this report to either be private or public. If you specify public, this report
can be seen and run by others. If you specify private, only you can see the report.

Fields for Report

Select the fields that you want to be present in the report. The fields will be displayed in
the report in the same order they are listed here.

Filter for Report

Select the filter that you want to use for this report.
Run this report when done

Select this option if you want to run the report immediately after saving the report.

If you want to see what the report looks like before saving the report, press the Preview
button and the report will be built and displayed. Click the OK. button to save the report.

Printing a Report

You can choose to run reports that you have created, default reports created by the
system, or reports created by others that have elected to share them by making them
public. To run you reports select the Reports =My Reports menu item and you will see
a list of your reports that you can run. To run other reports in the system, select the
Reports—>Public Reports menu item and select the specific report you would like to
run.

Deleting a Report

You can delete any report that you have created. To delete a report, select the
Reports—>Delete menu item, select the report you want to delete and then click the OK
button.

Previewing a Report

When you run a report in Defect Manager, you will get a chance to see the report in the
Report Pre-viewer window as show below.
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@] http://209.200.82.225 - All Open ltems - Microsoft Internet Explorer

e

~

~SO0FTWARE

File Edit View Favorites Tools Help

. — - .
- 1 b ) =" i oL -
@ Back </ \ﬂ \ELI Tl | A~ Search 7. Favorites €\t (=

BER
'lf:
b d
@ Morton AntiVirus &l =

S
All Open Items B
Id: 0
Product: Help Desk =
Release: R1.0
Priority: =not set>
Summary:
| wanna party, but it is broken!
Severity: <not =et=
User: Inbox
Status: Werified Az Bug
Entered On: 12/068/2005 - 08:18:28 PM
Last Updated: 02/01/2008 - 01:28:38 PM
Due On: 121152005
. NmeaddEd on . Omﬂm 01 ZESBPM ........ bv Demo User ............ t Log U pdatEd] ...............................................................
Status changed from ‘New" to “Verified Az Bug'
Note added on 011222006 - 08:50:53AM by DemoUser | (LogUpdateay
The Type has been changed to "Enhancement.
. NmeaddEd on . 12,\4}5;20.05 05 2320p|,n| ........ W Admm ................... t Log U pdatEd] ...............................................................
The due date has been set to 12/ 5/2005"
. Nmeaddeu on . 11,\0.5;20,05 03 2305PM ........ W Admm ................... t Log U pdatEd] ...............................................................
The reported date has been removed.
. NmeaddEd on . 12,\0.5;20,05 DE ZZEPM ........ m, Admm ................... t Ema, |' Sem] ..................................................................
From:admin@ywcurcompany.cem Tojretten@never.com Subject:RE: [Defect 0] What exactly is not working right. Can you give me some more
info?
. NmeaddEd on . 12,\0.5;20,05 03 1323PM ........ W Admm ................... t DpEHEd] .....................................................................
Opened with a Type of 'Defect’, Severity of "<not set=", Priority of "<not set=' in the "<not set=' Work Queue, User to "Inbox".
|d 3 ........................................................................................................................................................................
Product: Projectl |
@Ll Done  Internet

. Fisure: Report Pre-viewer Window

After the report has been created you can perform the following actions:

= Print the Report — Select the File=>Print menu item

* Print Preview the Report — Select the File 2Print Preview menu item
= Save the Report to Disk — Select the File > Save As menu item

= Page Setup - Select the File >Page Setup menu item
= Send the Report — Select the File >Send menu item

Using Other Reporting Tools

Defect Manager provides the following ways to access the Defect Manager issue data

from other tools. The following ways are described below.
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= Using SQL from a third party tool
= Exporting issue data
= Creating SQL from the database schema

Using SOL from a Third Party tool

At anytime you can get the SQL associated with a Defect Manager filter by selecting the
View—>View SQL menu item in the Issue Log. See the section Viewing the SOL Query
section for more information. You can use the SQL query in any SQL compliant
reporting tool.

Exporting Issue Data

You can export issues associated with a Defect Manager filter by selecting the Export
menu item in the Issue Log. See the section Exporting Issue Items section for more
information. After you export the data, you can then import it into any tool that supports
the data format that you specified when exporting the data.

Creating SOL from database schema

Defect Manager uses industry standard databases such as Access, SQL Server and
Oracle. You can always create your own SQL statements to retrieve the Defect Manager
issue data.

For additional information concerning the Defect Manager database schema, see the
section: Database Model in the Programmer API Guide. The database schema layouts
for the tables will show you the data names and structures of the repository database so
you can create your own SQL queries.

It is imperative that you do not modify any of the data. Doing so could damage the
integrity of the repository and you could cause irreversible damage.
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